startxwin/XWin won't start properly

Bradley, Mike
Tue Jun 29 14:50:00 GMT 2010

From: Bradley, Mike 
Sent: Tuesday, June 29, 2010 10:47 AM
To: ''
Subject: startxwin/XWin won't start properly


All was good, till a couple weeks ago when I added some packages to cygwin, and several packages where also upgraded.  Then xterm response time became very slow.  I tried a second upgrade yesterday, and now I cannot even start an xterm, nor will startxwin start properly.  This is a company computer which has Symantec anti-virus.  I tried disabling that as well.

Here is the most obvious symptom:

% echo $DISPLAY
% /usr/bin/startxwin.exe

waiting for X server to begin accepting connections .
giving up.
/usr/bin/startxwin:  Socket type not supported (errno 124):  unable to connect to X server
/usr/bin/startxwin:  No such process (errno 3):  Server error.

Notice the value of $DISPLAY above, which does not match whats in XWin.0.log (it has :0.0).  No idea how/why that happens.  

-------------- next part --------------
A non-text attachment was scrubbed...
Name: XWin.0.log
Type: application/octet-stream
Size: 4878 bytes
Desc: XWin.0.log
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck.out
Type: application/octet-stream
Size: 141832 bytes
Desc: cygcheck.out
URL: <>
-------------- next part --------------
Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list