Fwd: Can't start X after upgrading to cygwin1.7

Andrew Senior aws@andrewsenior.com
Sat Jan 16 17:56:00 GMT 2010

I've had cygwin installed for a year on my Thinkpad T61, running
Windows XP professional, and just ran the latest setup.exe from
At installation time there were some complaints about in use files,
though I wasn't to my knowledge running any cygwin processes at the
I now can't run X with startxwin.exe (no process appears, no icon in
the system tray, clients won't start)
It (and startx, xinit, Xwin :0)  gives me no logging on the console
(an rxvt window).
No /var/log/Xwin.0.log is written, nor anywhere else I can see in /var/log
I've tried reinstalling all the X & base packages I can find, or
uninstalling and reinstalling a few (including xinit and xorg-server).
I've also rebooted several times since first trying this.
The start menu icons give me no feedback either, except "idle" which
says "Error: could not start C:\Cygwin\bin\idle -display"
running xterm, xeyes on the command line gives no error message either.
Does anyone have any suggestions please?
(One odd thing I notice with 1.7 is that when starting rxvt  -e
/usr/bin/bash -login it puts me in /bin, whereas it used to put me in
my home directory. ~ and $HOME both correctly resolve to c:/aws which
is in fstab as /home/aws, as well as listed if I type "mount". This
happened without running /bin/copy-user-registry-fstab, and that
didn't put anything in /etc/fstab.d/.
Another is that four packages are always scheduled to be installed (as
New) in "partial" view of setup.exe : glib, gtk+, imlib, tetex, but
never seem to be installed, nor are there any failure messages.)
I attach a cygcheck output, though I notice various things that look
like errors in it:
I was using http://www.gtlib.gatech.edu/pub/cygwin/ as my mirror, but
setup.exe complained it wasn't an official mirror, so the recent
installation was from anl.gov, and I tried pointing to waterloo.edu
more recently.
Also, it complains that things are hidden in my path by directories,
e.g. perl is hidden by a directory named perl. 'which perl' gives the
location of the binary.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck.out
Type: application/octet-stream
Size: 67603 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin-xfree/attachments/20100116/da8c5392/attachment.obj>
-------------- next part --------------
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

More information about the Cygwin-xfree mailing list