BitDefender prevents installation and execution of Cygwin and Cygwin-x

Donald R. Ziesig
Wed Jan 13 01:23:00 GMT 2010

After upgrading to WinXP last month (I don't like to rush in to things) 
cygwin, cygwin-x, and NX-Client ceased to function.  (To make a long 
story short, I had changed to BitDefender at the same time, but had 
forgotten that).  I blamed the problem on the OS upgrade, not realizing 
that the problem was with the AV software.

I tried everything I could think of, to the point where I deleted all 
files associated with both cygwin and NX, then searched the registry and 
deleted all references to Cygnus, cygwin and nx-client, all to no 
avail.  I then re-installed only cygwin (the default minimum) but got 
the same symptoms:  Error messages in the /etc/postinstall script 
processes which translated to 0xC000000D (access violation) occurred on 
each an every entry in the script.  I finally found a web entry that 
suggested that this error could be caused by AV software (although it 
did not mention BitDefender by name).  In desperation, I erased all 
cygwin files yet again, put BD in GAME mode, and re-installed the 
default cygwin.  The install was successful so I added cygwin-x which 
also installed and ran successfully.  I  thought I'd push my luck so I 
also installed NX-client.  It worked as well!

Since I didn't like to leave my systems in Game (very permissive) mode, 
I switched BD back to its normal operating mode.  All the cygwin stuff 
stopped working.  Back to Game mode.  Everything works.  Sent nasty-gram 
to BitDefender (not really nasty, but let them know of the  problem and 
asked for solution).

I had the same problem on machines running Vista and Win7 (which also 
recovered in BD Game mode) so I think the problem is wide-spread.

I'm posting this in the hope that it helps others who may be beating 
their heads against the wall.

Don Ziesig

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list