xterm doesn't open on start (was: checkX problems)

Timares, Brian (Patriot) Brian.Timares@va.gov
Fri Nov 27 20:29:00 GMT 2009

Lothar Brendel wrote:
>Timares, Brian (Patriot) wrote:
>> Nothing works.  1.7 doesn't work for me out-of-the-box (yes, I ripped
>> it all out and tried it fresh :-)
>> I open a DOS box and check processes and see bash running with an l
>> a 1 in the left columnn, but nothing appears.  If I launch an Xterm
>> it opens up.  It seems some of the login thing happen, but when I add
>> in my ssh-agent starting script, since it requires input, it fails
>> (http://mah.everybody.org/docs/ssh is the script I use).
>> Any other ideas?
>Doen't look like the issue 
>http://cygwin.com/ml/cygwin-xfree/2009-11/msg00174.html to me.
>My guess: It's the old checkX-problem again because you're using
>0.3.0-1 of the run2-package. Do to some reason unknown to me, that's
>default version. But we need 0.3.1-1, which you only get when
>(triple-)clicking its circular double-arrow (how's that thingy called
>in the Utils category.

Tried it, including changing XWin Server to
C:\cygwin\bin\run2.exe /usr/bin/startxwin.bat

but it didn't help.  I next changed the obvious line in startxwin.bat to
SET RUN=%CYGWIN_ROOT%\bin\run2 -p /usr/bin
then it didn't start at all.

Removing that line, it is back to its previous behavior.  The only line
with checkX in it in my startxwin.bat is:
%RUN% checkX -wait -d %DISPLAY% -t 12

FWIW, here are my processes:
C:\cygwin\bin>ps auxwww
     3556       1    3556       3556    0 180490 13:15:43 /usr/bin/bash
     2400       1    2400       2400    ? 180490 13:15:44
I    2496    3556    3556       3700    0 180490 13:15:45
     3024       1    3024       3024    1 180490 13:19:58 /usr/bin/ps

If I take the ssh-agent and ssh-add parts out, I get bash and ps by

And my environment variables related to Cygwin:
C:\cygwin\bin>set|egrep "CYGWIN|LANG"

I don't know that I have all the right fonts in this installation, but 
based on the above 2 settings I think it shouldn't matter.
C:\cygwin\bin>grep ^font- cygcheck.out
font-adobe-dpi75               1.0.1-1
font-adobe-utopia-type1        1.0.2-1
font-alias                     1.0.2-1
font-bh-lucidatypewriter-dpi75 1.0.1-1
font-bitstream-vera-ttf        1.10-1
font-cursor-misc               1.0.1-1
font-daewoo-misc               1.0.1-1
font-encodings                 1.0.3-1
font-isas-misc                 1.0.1-1
font-jis-misc                  1.0.1-1
font-misc-misc                 1.1.0-1
font-xfree86-type1             1.0.2-1

OK, I added ALL fonts (why not?) and have included a new cygcheck.out
but no luck.  To get the Xserver icon in the taskbar icon area to show
I have to launch XWin Server twice :-(

-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck.out
Type: application/octet-stream
Size: 62024 bytes
Desc: cygcheck.out
URL: <http://cygwin.com/pipermail/cygwin-xfree/attachments/20091127/df7d332f/attachment.obj>
-------------- next part --------------
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

More information about the Cygwin-xfree mailing list