cygwinx 1.7 beta - crashes runing virt-manager

Michael Breuer
Mon Nov 23 17:06:00 GMT 2009

Ok - just one more FYI - after a shutdown and restart, I once again need 
-noclipboard... so -extension Composite and -noclipboard are working, 
-noclipboard seems to fix an intermittent problem.
Michael Breuer wrote:
> Ok - just an FYI - F12+Cygwin 1.7 seems rock solid with -extension 
> Composite. Been up for a while now, tried all sorts of stuff that was 
> problematic earlier. The only anomaly I encountered (minor) was the 
> cursor not tracking correctly in a Virt-viewer window. That was 
> probably pushing things anyway as the proper way is to run VNC 
> remotely, not in a remote X session... but I figured I'd try to break it.
> Michael Breuer wrote:
>> Ok - that worked. Was able to remove -noclipboard as well. Will use 
>> for a while and make sure it stays up... so far, so good.
>> Jon TURNEY wrote:
>>> On 20/11/2009 04:04, Michael Breuer wrote:
>>>> Connecting to F12 running Gnome, running python based applications
>>>> causes Xwin to segfault. For example, running virt-manager kills Xwin
>>>> immediately. Most of the F12 admin tools exhibit this behavior. I 
>>>> tried
>>>> -swcursor based on some old discussions on this list regarding Java
>>>> crashing Xwin (from 2007). Doesn't help now :(
>>>> Anyone have suggestions?
>>> I can't even use XDMCP to log-in to Fedora 12 (Constantine), due to 
>>> random segfaults :-(
>>> These seem to be due to a bad interaction between the damage 
>>> tracking for the Composite extension and damage tracking for the 
>>> shadow framebuffer.
>>> So can you try disabling the composite extension with '-extension 
>>> Composite'? (note the captialization)

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list