Problem with new xinit - console window doesn't open (but bash starts)

Sun Nov 22 20:25:00 GMT 2009

On 20/11/2009 15:05, Jim Reisert AD1C wrote:
> I tried adding the missing fonts. I tried SET LANG=C
> Starting the X server is still unpredictable.

Does this mean it sometimes works and sometimes doesn't?
Or does it mean it fails in different ways each time you try?

>  Now my log file (attached) shows:
> It also claims another window manage is running (and therefore shuts
> down), which is untrue (there is no other Xwin process running).

Since I have touched 'check for another window manager' code recently, I was 
kind of expecting to see that I'd managed to break it in some way, but..

I'm not quite sure what to make of that log file. This is very strange.

If you look for "(II) xorg.conf is not supported", you'll see that it looks 
like that server starts again about half-way through.

I did wonder if you were managing to somehow start two copies of XWin 
near-simultaneously, but I don't think that would produce a logfile like that 
(since it's not opened in append mode, you probably get the logfile from the 
last process to close it or something like that)

An alternative explanation is that there is a really inconveniently timed 
server regeneration happening: just after the internal client threads have 
been created, but before they can connect, so they are still hanging around to 
be accepted by the next server generation.

If we did have twice as many threads as we are supposed to, that would explain 
the final failure due to another WM running (as there's another WM thread, 
note that there are two 'winMultiWindowXMsgProc - Hello' lines)

No idea why the server is regenerating though, needs more meditation :-)

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list