Can't read lock file

Fri Nov 13 12:54:00 GMT 2009


> Which is bad since FAT32 has no security at all. Any process of any
> user on the machine can overwrite any file, even in the Windows folder.
> NTFS is much more secure and has a couple of features you never get with
> FAT32, and hardlinks are only one minor advantage. You should really
> update the filesystem to NTFS using the on-board convert.exe tool.

Well. I took the advice and converted both FAT32 systems (one for 1.5 
and one for 1.7) to NTFS. I quite like some of the file management 
consequences - e.g. chkdsk output, more efficient use of space - but 
working within Cygwin I'm not a happy bunny. I am sure that in many 
parallel universes the step you have advised results in huge benefits, 
but so far I can only report detriment to [1] use and [2] understanding.

(I know [1] that requests/ complaints/ comments should not be too 
user-specific and as for [2] I'm really just hanging myself out to dry. 
But here goes ...)

I operate both Cygwins 1.5 and 1.7 on a partitioned portable drive 
hooked up to different machines at different times. After changing to 
NTFS I find

statements of folder permissions completely incomprehensible e.g. the + 
in drwxrwxrwx+;
also that they do not alter after chmod instructions in the way I was 
that there are MANY additional user names and group names including 
?????????? ;
that files I worked on on Machine 1 now produce "Permission denied" when 
I try to work on them on Machine 2

All right, all of the above merely make manifest a complete lack of 
understanding of permissions, privileges, rights, etc. But it is after 
all "my" mobile drive, and every file on it was put there by me, is 
owned by me in some sense, and I ought to be able to do stuff.

Finally (and I have tried to search for a solution) I alias ls as "ls 
--color" and had some lovely rxvt* xterm* and gnuplot* color schemes set 
up in ~/.Xdefaults. Now the rxvt* and xterm* color schemes have been 
lost (to be replaced   by, I assume, some standard set, with a 
particularly horrid colour combination for directories  (fg blue bg 
green). Confusingly, realised gnuplot* colors are still as set in 
.Xdefaults. Is there a way I can recover what I want for rxvt and xterm 
(maybe by putting the instructions into a different file).

I think I will revert to FAT32 partitions and maybe put up with a 
working if not current XWin in 1.7. Like my experience with mobile 
phones, there is a threshold of sophistication beyond which I am just 
plain incapable of making progress, and the conversion of FAT32 to NTFS 
seems to have crossed that threshold for me with its unintended (or 
unexpected anyway) consequences. It is a marvellous advance in security 
I am sure (and I am very appreciative that Corinna and Jon took this up 
and responded to me) but I guess it just isn't for me.

Thank you. If meanwhile you can point me somewhere for a solution to the 
lost colour schemes, I would be very grateful.


Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list