Cut & Paste problem between X windows
Thu Nov 12 20:24:00 GMT 2009


I just discovered that setting "LANG=en_US.UTF-8" in my environment solved the problem with pasting into an xterm.  Not exactly sure why this fixed that problem, anybody know?

I still have the problem with clipboard sharing between windows and cygwinx, though.  Could this also be related to the LANG environment variable?  Is there some other value other than en_US.UTF-8 required to get it to work?

-Dave Levi

----- Original Message ----- 
Sent: Thursday, November 12, 2009 3:11:22 PM GMT -05:00 US/Canada Eastern 
Subject: Re: Cut & Paste problem between X windows 


I am having trouble with pasting text into xterm windows, in cygwin1.7. The problem I'm having seems like the same one recently reported in this thread 'Cut & Paste problem between X windows'. However, I am using a microsoft mouse (the problem in that thread was with a logitech mouse). I was wondering if anybody else is seeing the problem with a microsoft mouse, and whether there is a workaround/fix. 

I installed cygwin1.7 yesterday (in place of 1.5 which I had been using). Basically, I can select text in an xterm using mouse buttons 1 and 3, but cannot paste using button 2. Clicking with button 2 has no effect. 

In general, cygwinx is recognizing mouse button 2, as I can use it for other things in other X clients without any problems. Also, I've tried xev, and can see the ButtonPress and ButtonRelease events for button 2. 

I tried installing the microsoft intellipoint software, and in it, I set the action for button 2 to 'Middle Click'. This seemed equivalent to what was suggested previously for the logitech mouse, using the logitech 'setpoint' software. But this didn't seem to have any effect. 

One other issue, not sure if this is related, but when I select text in an xterm, I cannot paste it in windows. It seems like the selection is not being shared between cygwinx and windows, like it was with cygwin1.5. I am starting Xwin.exe with the -clipboard option, just as I was with cygwin1.5, but selection sharing just doesn't seem to work. 

Anybody have any ideas about these problems? Thanks! 

-Dave Levi 

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list