'run xterm' fails to open a window

Florent Fievez mailing@fievel.be
Wed Nov 4 08:54:00 GMT 2009


2009/11/3 Linda Walsh <cygwin@tlinx.org>:
> 1) to Florent Fievee, (you don't need to answer if you have no good
>  reason, but if you do, I'm curious as to your reasoning) --   Why did you
> copy Ken's complete note as into your response, when you
>  simply has to say "me too"?

I simply clicked on "reply" button of my webmail. I will not do it again ;-)

> 2) to both Florent and Ken?
>  In addition to Gery Herbozo Jimenez's response and question to you,
>  ( "Have you tried just starting the XWin server first and the the
>  xterm? it looks like the X server doesn't recognize that line
>  command." ),
>  a) Have you tried starting 'xterm' without 'run' ?

Yes, it works without problem but a cmd window remain and that is
annoying. To explain exactly my situation, I have a Windows cmd script
which try to launch a bash script.

------- rxvtwin.cmd ------
@echo on


if defined CYGWIN_ROOT goto :OK
set CYGWIN_ROOT=%~dp0

SET RUN=%CYGWIN_ROOT%\bin\run -p /usr/bin


%RUN% %CYGWIN_ROOT%\bin\bash /usr/local/bin/rxvtwin.sh %*

I call it in windows shortcut with a "user@host" as parameter and it
launch a rxvt terminal with a ssh session to the host and background
color depending on host.
If instead of "%RUN% %CYGWIN_ROOT%\bin\bash /usr/local/bin/rxvtwin.sh
%*" I launch "%CYGWIN_ROOT%\bin\bash /usr/local/bin/rxvtwin.sh %*", it
So it seems to be really run which has an issue.

>  b) I see you have started 'Xwin'.  Do either of you know what display
>     'XWin' started itself on?         If you specified no value, it probably
> created the display ":0.0".

Yes my server is running on display 0.0 and I specify it in DISPLAY
environment variable.
 (I specified it in both bash and cmd script since I don't know if
environment is inherited by bash process when I run it)

>   <Your cygwin path>\bin\bash.exe -c 'DISPLAY=:0 xterm'
>   for cygwin path='C:\cygwin':
>      C:\cygwin\bin\bash.exe -c 'DISPLAY=:0 xterm'
>        or
>      C:\cygwin\bash\bash.exe -c 'xterm -display :0'
>   for cygwin path= 'C:\':     (my value)
>      C:\bin\bash.exe -c 'DISPLAY=:0 xterm'
>                or
>     C:\bash\bash.exe -c 'xterm -display :0'
> The above two commands work on WinXP and Vista under the 1.5.x series
> of Cygwin.

It don't work as I expected since what I have explained before.
But I have a little track : My office has given me a new computer and
with the old I had no problem with the same scripts, the difference
between the two is that the old one was Windows XP 32bits and the new
one is Windows XP 64 bits.
I tried first with cygwin 1.5 and I installed also cygwin 1.7 (I have
the same problem in both installation).

Best Regards,

Florent Fievez

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

More information about the Cygwin-xfree mailing list