XWin freezes on xkbcomp

Zdrojewski, Tye tye.zdrojewski@lmco.com
Mon Jul 6 17:38:00 GMT 2009

I only say that this is a "big" problem because it cripples my ability
to run cygwin/X.  I guess I'm surprised no one else has reported this,
because I haven't done anything unusual (that I know of).

Yes, my *working* installation is a bit older.

I use the dvorak layout (not trying to be secretive).

Setxkbmap was not installed (missing dependency in setup?).  So, I
installed it, but the problem persisted.

After starting XWin and killing the hung process, I am able to run the
command you suggested, but it just causes another hung XWin process to
be created.

If I run an X client (xfontsel, rxvt, etc), THEN run the setxkbmap
command, it works!  But as soon as I kill the last X client window, X is
frozen again with that hung process.

If I wait, X does eventually come back, but it seems to take about 5


> -----Original Message-----
> From: Jon TURNEY [mailto:jon.turney@dronecode.org.uk]
> Sent: Monday, July 06, 2009 11:40 AM
> To: cygwin-xfree@cygwin.com
> Cc: Zdrojewski, Tye
> Subject: Re: XWin freezes on xkbcomp
> On 02/07/2009 19:08, Zdrojewski, Tye wrote:
> > After recently reinstalling cygwin, XWin freezes when I try to run
> > There are two XWin processes running when it is frozen.  When the
> > process with the smaller memory footprint was killed, the following
> > into the log, and it appeared to unfreeze for a moment.
> >
> > (EE) XKB: Could not invoke xkbcomp
> >
> > (EE) XKB: Couldn't compile keymap
> >
> > (WW) Couldn't load XKB keymap, falling back to pre-XKB keymap
> >
> > I started XWin with the -kb option, which stopped the freezing, but
> > don't use the standard US keyboard, so this isn't really on option
> > me.
> I suggest you test if you can run xkbcomp at all, e.g.
> xkbcomp --help
> setxkbmap de -print | xkbcomp -w3 -xkm - localhost:0.0
> (replace 'de' with the secret keyboard layout you want to use)
> > I also notice that /etc/X11/xkb/ is not there, along with several
> > directories that ARE there on another PC with a working cygwin
> >
> > $ ls /etc/X11
> >
> > app-defaults/  system.XWinrc*  xinit/
> This is normal
> > Seems like there ought to be more there, because this is what that
> > looks like on the working install:
> >
> > app-defaults/  fs/  lbxproxy/  proxymngr/  rstart/  twm/  xdm/
> > xkb/  xserver/  xsm/
> This looks like an older (pre-X11R7.4) installation (or has
> left
> over from an older installation.  For all I know that xkb/ is empty
:-) )
> > This seems like a BIG problem.  Hopefully this is something already
> > being worked on or already fixed.
> I think you are the only person who has reported a problem like this,
> I'm
> afraid I can't agree with any of those statements.

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

More information about the Cygwin-xfree mailing list