Can't start Xwin server using latest Cygwin 1.7, Xorg server, etc.

George Barrick
Tue Dec 8 15:10:00 GMT 2009

                              2009.12.08.13:41:22 UT

Hi Jim,

     I've been having the same difficulty.  I start
Xwin via the startxwin.bat script, my xterm is then
spawned, but crashes taking Xwin with it.

     I thought that I had solved the problem last week
when I read on the regular cygwin newsgroup about setting
the CGWIN and LANG environment variables.  I now have
things set up as:

CYGWIN tty notitle glob
HOME E:\gbarrick

I have not seen any discussion of the LC_TIME variable,
and had the impression from several threads that my setting
of LANG would help with this problem.

     The problem recurred a few days later, and I kind
of gave up, deciding to wait for the next cygwin-1.7
dll.  When I got the cygwin-1.7.0-68, my xterm worked
again, but then the next morning it was crashing on
start-up as before in a situation where I had installed
nothing that was new.

     I tried the 'rebaseall' trick, as my reading hinted
that this might alleviate the problem:

D:\cygwin\bin> ash.exe
$ PATH=. rebaseall -v

And I got no change in the behavior.

     I've appended my startxwin.bat file, and some abbreviated
versions of my XWin.0.log file and the output of cygcheck -v to
the end of this message.  I'm pretty certain that I have no
other window managers running when I try to start XWin, as I
visit the windows task manager and kill off any orphaned
xwin and bash processes that I see (ninety-nine percent
are bash).

     I've run the experiment where I do not use the
-multiwindow option of XWin, and it _does_ work under those
circumstances, but that configuration really cramps my work-flow.
My alternative over the past few days has been to use the
rxvt-native command window.

     Like you, I'm hoping that better informed folks will
read this.


<file: startxwin.bat - most comments removed>
 @echo off

if defined CYGWIN_ROOT goto :OK
set CYGWIN_ROOT=%~dp0\..

SET RUN=%CYGWIN_ROOT%\bin\run -p /usr/bin
SET RUNTWO=%CYGWIN_ROOT%\bin\run2 -p /usr/bin



if not exist %CYGWIN_ROOT%\tmp\.X11-unix\X0 goto CLEANUP-FINISH
attrib -s %CYGWIN_ROOT%\tmp\.X11-unix\X0
del %CYGWIN_ROOT%\tmp\.X11-unix\X0

if exist %CYGWIN_ROOT%\tmp\.X11-unix rmdir %CYGWIN_ROOT%\tmp\.X11-unix

%RUN% bash -l -c "XWin -multiwindow -clipboard -silent-dup-error"
REM %RUN% bash -l -c "XWin -multiwindow -silent-dup-error"
REM %RUN% bash -l -c "XWin -silent-dup-error"
REM %RUNTWO% /usr/bin/XWin.xml

%RUN% checkX -wait -d %DISPLAY% -t 12

REM %RUN% xterm -e /usr/bin/bash -l
%RUN% xterm -rw -sb -rightbar -geometry 128x44+72+60 -e /usr/bin/bash -l

<file: Xwin.0.log - only the last few lines>
2009-12-08 07:50:44 winClipboardProc - DISPLAY=:0.0
2009-12-08 07:50:44 winInitMultiWindowWM - XOpenDisplay ()
          returned and successfully opened the display.
2009-12-08 07:50:44 winMultiWindowXMsgProc - XOpenDisplay ()
          returned and successfully opened the display.
2009-12-08 07:50:44 winClipboardProc - XOpenDisplay ()
          returned and successfully opened the display.
2009-12-08 07:50:47 winMultiWindowXMsgProc - XOpenDisplay ()
          returned and successfully opened the display.
2009-12-08 07:50:47 winMultiWindowXMsgProc - another
          window manager is running.  Exiting.
2009-12-08 07:50:47 winClipboardProc - winClipboardFlushWindowsMessageQueue
          trapped WM_QUIT message, exiting main loop.
2009-12-08 07:50:47 winClipboardProc - XDestroyWindow succeeded.
2009-12-08 07:50:47 winClipboardIOErrorHandler!

<file: cygcheck_output.txt - many libs and irrelevant packages clipped out>
Cygwin Package Information
Package                 Version             Status
_update-info-dir        00834-1             OK
base-cygwin             2.0-1               OK
base-files              3.9-2               OK
base-passwd             3.1-1               OK
bash                    3.2.49-23           OK
bc                      1.06-2              OK
binutils                2.19.51-1           OK
bzip2                   1.0.5-10            OK
cdrecord                 OK
coreutils               7.0-2               OK
cygrunsrv               1.34-1              OK
cygutils                1.4.1-2             OK
cygwin                  1.7.0-68            OK
cygwin-doc              1.5-1               OK
font-adobe-dpi75        1.0.1-1             OK
font-alias              1.0.2-1             OK
font-daewoo-misc        1.0.1-1             OK
font-encodings          1.0.3-1             OK
font-isas-misc          1.0.1-1             OK
font-jis-misc           1.0.1-1             OK
font-misc-misc          1.1.0-1             OK
font-xfree86-type1      1.0.2-1             OK
fontconfig              2.7.3-1             OK
mkfontdir               1.0.5-1             OK
mkfontscale             1.0.7-1             OK
ncurses                 5.7-16              OK
openssh                 5.3p1-1             OK
openssl                 0.9.8l-2            OK
rebase                  3.0.1-1             OK
run                     1.1.12-11           OK
run2                    0.3.2-1             OK
rxvt                    20050409-21         OK
tar                     1.22-1              OK
termcap                 5.7_20091114-13     OK
terminfo                5.7_20091114-13     OK
terminfo0               5.5_20061104-11     OK
util-linux              2.14.1-1            OK
w32api                  3.14-1              OK
wget                    1.11.4-4            OK
which                   2.20-2              OK
wodim                    OK
X-start-menu-icons      1.0.4-1             OK
xauth                   1.0.4-1             OK
xcursor-themes          1.0.2-1             OK
xfig                    3.2.4-7             Incomplete
xfig-lib                3.2.4-7             OK
xfontsel                1.0.2-2             OK
xinit                   1.2.0-1             OK
xkbcomp                 1.1.1-1             OK
xkeyboard-config        1.7-1               OK
xlsfonts                1.0.2-1             OK
xmodmap                 1.0.4-1             OK
xorg-scripts            1.0.1-1             OK
xorg-server             1.7.1-3             OK
xrdb                    1.0.6-1             OK
xterm                   251-1               OK
xwininfo                1.0.5-1             OK
xz                      4.999.9beta-10      OK

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list