cygwin-x xterm not compatible with windows 7?

Mike Ayers
Mon Dec 7 23:13:00 GMT 2009

> From: [mailto:cygwin-xfree-
>] On Behalf Of
> Sent: Saturday, December 05, 2009 4:34 PM

>     Sorry to take a bit of time to get back to you.  I am attaching the
> files you requested.  I am not familar with the cygwin x server log,
> but it looks like *that* starts up.  It's just that xterm cannot
> connect.

	That does appear to be the case.

>     You mentioned that the server listenens on  You mean a
> port?

	No.  "" is the broadcast IP address.  When a server listens on that address, it listens to every interface on the computer, so it wouldn't matter if you tried connecting to localhost or the external address (i.e. leave your DISPLAY pointing to

> I'm asking because what I have noticed about Windows 7
> Home Edition is that even though I have created a user for myself with
> administrative priveleges, unless I tell the OS that I want to
> run a program as the administrator it will default to the privileges
> for an
> ordinary user.  I don't know a way to turn this off, yet.

	I don't believe there is a workaround, unfortunately.  Vista has the same issue.

> So, is it possible that the port that the cygwin-x server is listening
> on
> belongs to the administrator and the xterm session when it is
> launched cannot write to this port as a result?

	No, there are no ownership issues sending packets to ports.  My suspicion would be that the non-administrator X server process would not be allowed to open the listeneing port, or be firewalled off, but neither can be the case if xcalc works.  Have you tried running xterm from a cygwin console after the server has started?

>  I tried running DOS
> cmd as
> the administrator btw, with no better results.

	Which DOS command?



More information about the Cygwin-xfree mailing list