cygwin-x xterm not compatible with windows 7?
Sun Dec 6 00:33:00 GMT 2009

Hi Mike:
    Sorry to take a bit of time to get back to you.  I am attaching the 
files you requested.  I am not familar with the cygwin x server log,
but it looks like *that* starts up.  It's just that xterm cannot connect.

    You mentioned that the server listenens on  You mean a port? 
I'm asking because what I have noticed about Windows 7
Home Edition is that even though I have created a user for myself with 
administrative priveleges, unless I tell the OS that I want to
run a program as the administrator it will default to the privileges for an 
ordinary user.  I don't know a way to turn this off, yet.
So, is it possible that the port that the cygwin-x server is listening on 
belongs to the administrator and the xterm session when it is
launched cannot write to this port as a result?  I tried running DOS cmd as 
the administrator btw, with no better results.



----- Original Message ----- 
From: "Mike Ayers" <>
To: <>
Sent: Thursday, December 03, 2009 2:18 PM
Subject: RE: cygwin-x xterm not compatible with windows 7?

>> From: [mailto:cygwin-xfree-
>>] On Behalf Of
>> Sent: Thursday, December 03, 2009 1:47 PM
>>     I sent this post earlier this week and have not received any
>> replies.
>> If this is the wrong place to post this,
>> please let me know where I should.
> This is the place, but I don't know how many of us have tried using 64 bit 
> Windows 7 yet.  I know I haven't, but I'll offer advice anyway.  (What's 
> the smiley for "evil leer"?)
>>      I just bought a new PC with windows 7 64 bit, build number 7600,
>> version 6.1.
>> I downloaded a fresh install of cygwin and cannot get cygwin-x xterm
>> running.  Cygwin version is 1.7.0(0.218/5/3)
>> I tried running the cygwin-x XWin Server shortcut command line from a
>> cmd
>> window to get the error output:
>> C:\cygwin\bin\run.exe /usr/bin/startxwin.bat
>> and see this:
>> "/usr/bin/xterm Xt error: Can't open display:"
>> this seems to be coming from this command in the batch file:
>> :\Users\princess>C:\cygwin\bin\\..\bin\run -p /usr/bin xterm -e
>> /usr/bin/bash -
>> usr/bin/xterm Xt error: Can't open display:
> ...implying that the server didn't start.
>> If I kill the server and run the script again, I'll get a
>> STATUS_ACCESS_VIOLATION error, indicating
>> some sort of shared memory corruption.  I then have to restart the PC.
>> I
>> checked to see if there
>> was more than one cygwin1.dll in response to earlier posts about this
>> error
>> and there is only one.
>> I tried turning off the windows firewall.  That helps in other ways,
>> because
>> other cygwin network
>> utilities, such as nslookup were blocked until I did that.
>> I tried changing the display from to the IP address of the
>> machine.
> I believe the X server listens on, so that shouldn't make a 
> difference.
>> Basically, I have a fresh machine with windows 7 and a fresh install of
>> cygwin and I can't get
>> xterm to work.  Anyone have any ideas?  Or is this just a windows 7
>> thing,
>> and I'll have to give
>> up on cygwin-x for a while?
>> BTW, other shortcuts in the cygwin-x start folder work, such as bitmap
>> and
>> xcalc, just not the
>> Xwin server and xterm.
> How can xcalc work if the server doesn't start?!
> Please send your /var/log/XWin0.log and cygcheck.out (cygcheck -s -v -r 
>  >cygcheck.out) as attachments in the hope that they will inspire.
> Thanks,
> Mike
-------------- next part --------------
A non-text attachment was scrubbed...
Name: XWin.0.log
Type: application/octet-stream
Size: 4206 bytes
Desc: not available
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck.out
Type: application/octet-stream
Size: 196453 bytes
Desc: not available
URL: <>
-------------- next part --------------
Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list