cygwin-x xterm not compatible with windows 7?

Mike Ayers
Thu Dec 3 22:18:00 GMT 2009

> From: [mailto:cygwin-xfree-
>] On Behalf Of
> Sent: Thursday, December 03, 2009 1:47 PM

>     I sent this post earlier this week and have not received any
> replies.
> If this is the wrong place to post this,
> please let me know where I should.

	This is the place, but I don't know how many of us have tried using 64 bit Windows 7 yet.  I know I haven't, but I'll offer advice anyway.  (What's the smiley for "evil leer"?)

>      I just bought a new PC with windows 7 64 bit, build number 7600,
> version 6.1.
> I downloaded a fresh install of cygwin and cannot get cygwin-x xterm
> running.  Cygwin version is 1.7.0(0.218/5/3)
> I tried running the cygwin-x XWin Server shortcut command line from a
> cmd
> window to get the error output:
> C:\cygwin\bin\run.exe /usr/bin/startxwin.bat
> and see this:
> "/usr/bin/xterm Xt error: Can't open display:"
> this seems to be coming from this command in the batch file:
> :\Users\princess>C:\cygwin\bin\\..\bin\run -p /usr/bin xterm -e
> /usr/bin/bash -
> usr/bin/xterm Xt error: Can't open display:

	...implying that the server didn't start.

> If I kill the server and run the script again, I'll get a
> STATUS_ACCESS_VIOLATION error, indicating
> some sort of shared memory corruption.  I then have to restart the PC.
> I
> checked to see if there
> was more than one cygwin1.dll in response to earlier posts about this
> error
> and there is only one.
> I tried turning off the windows firewall.  That helps in other ways,
> because
> other cygwin network
> utilities, such as nslookup were blocked until I did that.
> I tried changing the display from to the IP address of the
> machine.

	I believe the X server listens on, so that shouldn't make a difference.

> Basically, I have a fresh machine with windows 7 and a fresh install of
> cygwin and I can't get
> xterm to work.  Anyone have any ideas?  Or is this just a windows 7
> thing,
> and I'll have to give
> up on cygwin-x for a while?
> BTW, other shortcuts in the cygwin-x start folder work, such as bitmap
> and
> xcalc, just not the
> Xwin server and xterm.

	How can xcalc work if the server doesn't start?!

	Please send your /var/log/XWin0.log and cygcheck.out (cygcheck -s -v -r >cygcheck.out) as attachments in the hope that they will inspire.



More information about the Cygwin-xfree mailing list