xterm doesn't open on start (was: checkX problems)

Lothar Brendel lottas.junk@geekmail.de
Wed Dec 2 23:18:00 GMT 2009


> More information as promised, after getting the new run and checkX
> (run2) packages announced this morning.
> $ checkX -v
> run2 0.3.2

0.3.2 announced? I didn't get any such message, and setup still only offers 
0.3.1-1 to me.

> VHAISBTIMARB@isb-timaresbrian-lt ~
> $ XWin -multiwindow &
> [1] 5004
> VHAISBTIMARB@isb-timaresbrian-lt ~
> $ Welcome to the XWin X Server
> Vendor: The Cygwin/X Project
> Release: (10701000)
> Build Date: 2009-11-11
> ----- UNQUOTE -----

Yes, the log didn't show anything unusual. (BTW: You got it from 
/var/log/XWin.log.0, not from stdout, right?)

> After quitting and destroying any processes from a DOS window, trying
> startxwin.bat with echo on....
> First off all, nothing appeared (no X icon, no window).


> At this point I run "Cygwin Bash Shell" and from that window I run
> startxwin.bat and it works fine, even after closing the Cygwin Bash
> Shell.

Brief, running ``startxwin.bat'' from the Cygwin Bash Shell works while 
running it from a Windows Prompt (DOS window) does not. Right?

Ok, same check over there. In the Windows Prompt:

C:\cygwin\bin\run XWin

What does happen? Nothing?


Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

More information about the Cygwin-xfree mailing list