XWin wrong fonts after update

catia.lavalle@bechtle.com catia.lavalle@bechtle.com
Thu Apr 2 07:42:00 GMT 2009

Thanks a lot Dirk! 

Your link did the trick. I have installed the font-adobe-dpi75 and now the 
remote application does work properly!
I have already saw the hint on the net of installing the abobe fonts but 
it was always correlated to emacs showing up with bad fonts ... but my 
emacs (xamacs) was showing up absolutely properly! that's why I assumed it 
was not my case!

I still do not understand why I had to install it. I mean:
1) Before it was not installed and the remote application was working 
properly. Even in the web page "Some packages dependencies have not yet 
been updated for the fonts they require " well it is a remote application 
so it should not have anything to do with "local package dependencies": 
either the font is there or not ..... I guess .. I might be wrong, I am 
not an X expert.
 2) I had a look now at the test system I have installed yesterday (cygwin 
fresh installed on the up-to-date version, not an update), which did 
always work. There the font-adobe-dpi75 are not installed and anyway it 

So again (that was my comment on my first mail which maybe was 
misunderstood): it seems to me that there is a difference between 2 
systems which are at the newest state now  but one of them was installed 
in the newest state, the other one was updated to the newest state.

I have executed the cygcheck -s -v -r > cygcheck.out command on both 
machines, I have noticed no special differences, obviously the 2 hardware 
are different, the software installed is different and in the test system 
there are much less cygwin packages installed being a test. Anyway I had 
more fonts installed on the productive system then on the test system 
(follow the list of fonts that were on the prod system which were not on 
the test

font-alias              1.0.1-1
font-bitstream-dpi75    1.0.0-1
font-bitstream-type1    1.0.0-1
font-encodings          1.0.2-1
font-misc-misc          1.0.0-1
ghostscript-fonts-other 6.0-1
ghostscript-fonts-std   8.11-1
).  (I can post the 2 complete outputs if you wish).

The thing which makes me still worried is: which other fonts should I 
extra install to be safe for "future applications". I explain: I am a 
sysadmin and it happens that I startup remotely graphical applications 
which would be unpleasant to be forced to stop while executing because of 
missing fonts (installing stuffs). 

For completeness I tell you the whole story:

* In the past I always started X with the Mortens X-Launcher with the 
multiwindow & clipboard options set (rest = default)
* yesterday I have started the X from the command line (from rxvt) with 
/usr/bin/XWin.exe :0 -clipboard -multiwindow . The "problem" was that I 
got no warning and no error whatsoever on console!!
* today I have tried to start X from the Start link (the 
/usr/bin/startxwin.bat ): nothing has started, no X no error.
 * then I have started X from command line (from rxvt) with 
/usr/bin/run.exe /usr/bin/startxwin.bat and I got on console an error:

<catia.lavalle@agdehenw00055:~/Eigene Dateien> /usr/bin/run.exe 
<catia.lavalle@agdehenw00055:~/Eigene Dateien> startxwin.bat - Starting on 
Windows NT/2000/XP/2003
Das System kann den angegebenen Pfad nicht finden.
Das System kann den angegebenen Pfad nicht finden.

(path not found)
and no I had no X.
* then I have started X from command line (from rxvt) with 
/usr/bin/startxwin.sh . I have got X, the same console output as yesterday 
+ DECISIVE the Warning "Warning: Cannot convert string 
"-adobe-helvetica-bold-r-normal--*-120-*-*-*-*-iso8859-*" to type 

It was then clear to me what to do.

So thanks again.

p.s. Note just to report: even now I get the same error using 
startxwin.bat, and on the test system there is no /usr/bin/startxwin* at 

p.p.s. @Phil: I work professionally with Unix/Linux Systems since more 
then 10 Years and I am a Dr. in theoretical Physics. There are for sure 
tons of things I do not know, I have never worked on and I  am not an 
expert on and I always welcome everybody teaching me something new, but 
for sure I am not stupid and DO  understand things I read, if I don't, I 
ask. I DO know very well the principle of free software and one of the 
main principles is" I help you, you help me and things go forward. not 
because I got paid for what I do but because I want to share my knowledge, 
my expertise and my time". That's why I find very low level and out of 
place such  no-point ,aggressive, self-satisfied answer in such mailing 
lists/forum. If you find my question stupid, just do not loose your time 
answering me, you have not to. 
And again on free software: it is exactly because I KNOW what free 
software is that I report problems (not only because I want them solved 
... there are other solutions without cygwin to have an X server 
running!!!). The fact that I report something not working, no matter why, 
is to be taken with an "ops" maybe we should fine-tune it for the next 
time so that such problems do not pop up, because, you can trust me there 
are for sure tons of people out there which have had the same problem and 
do not have the skill, the time, the will to report the problem and/or to 
"understand" (as you say) the solution. Free software for sure does not 
mean  you have to be an expert in everything you are willing to use!

Externe Mail : cygwin-xfree-owner@cygwin.com       01.04.2009    17:24

Gesendet von: cygwin-xfree-owner@cygwin.com
Bitte antworten an cygwin-xfree


Re: XWin wrong fonts after update

catia.lavalle@bechtle.com schrieb:

Please check the FAQ for informations about the update:

There are some changes in the location of file after the upgrade,
so you have to set up old start scripts for the X server to the new 

If you can not solve the problem with, the informations in the FAQ,
please follow the instructions for reporting a problem:
   Problem reports:       http://cygwin.com/problems.html
You can check the output of
   cygcheck -s -v -r > cygcheck.out
on both computers to see differences.

I think it is important to know how you start the X server on both 
computers and to check for differences in the start up scripts.


Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

More information about the Cygwin-xfree mailing list