using ssh-Y on Vista
Thu Mar 6 09:42:00 GMT 2008


I am having a problem with X-windows forwarding from a fresh  
installation of cygwin and X on Longhorn Vista (cygcheck.out  
attached). Basically when I do

ssh -vv -Y me@linuxserver

I get

debug2: x11_get_proto: /usr/X11R6/bin/xauth  list :0.0 2>/dev/null

(and the xterm hangs).

Here is what I tried having read all the postings I could find. Still no luck.

1. I've reinstalled Cygwin thrice completely from scratch including  
removing all files, changing permissions etc.

2. My Firewall and User Account Control are disabled. My Norton is  
UN-installed.   I renamed setup.exe to some other name. I am using  
Compatibility with WinXpSP2 and run the setup As Administrator.

3. I followed suggestions to rebaseall.

4. During install I pushed manually the postinstall script  
postinstall/  (killed and executed from bash; probably no  
connection though but I will mention that I fixed 'w' permissions to  
some folders etc.).

Now: My /usr/X11/bin/startx works fine, I can fork xterms  as usual.
I can ssh to me@linuxserver just fine, but I just can NOT do XWindows  
forwarding as in using ssh -vv -Y ****. My three other installations  
of cygwin-X that I have on Win2K and WinXP have worked nicely for the  
last few years and still do including  ssh -Y me@linuxserver.
So this is likely not a problem on my  linuxserver side ... ?

Any help will be greatly appreciated ... my apology if I did not find  
just the *right* posting ....  Thanks, Malgo

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list