solved: X compile fails for missing (internal?) symbols

Dick Repasky
Thu Aug 9 13:01:00 GMT 2007

The original problem report is

After that problem was solved, two others emerged. This message documents 
fixes for all three.

1) As posted earlier

xftpat.o:xftpat.c:(.text+0x3c2): undefined reference to `_FcPatternInsertElt'
xftpat.o:xftpat.c:(.text+0x3ce): undefined reference to `_FcPatternFindElt'

    The symbol names have changed as documented in That post
    contains two alternative patches, one that patches both xftint.h and
    xftpat.c and a second patch that changes only xftint.h with defines.
    The former patch worked for me, but the latter "even quicker" patch did
    not work for me.

2) Bad includes in lib/font/FreeType/ftfuncs.c
    Briefly, a #define symbol that specified a file to be included in
    a #include was not defined, and hence, the file to be included could
    not be found.

    The fix is dirty. Place the line

    #define HasFreetype2 NO

    in config/cf/host.def. I realize that X is supposed to be built using
    the installed cygwin freetype package, but I could not figure out
    how to get X to use the cygwin package.  By forcing HasFreetype2 to NO,
    X builds a copy of the library for itself. Maybe someone else knows
    or can figure out a better solution.

3) #include png.h fails.

    libpng is not specified as a dependency
    in, but is is
    needed to build X.

With those fixes X compiled for me.

Your mileage may vary,



Dick Repasky
Center for Computational Cytomics
UITS Cubicle 101.08
Indiana University

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list