Cannot Start X

Marco Schuler
Tue Aug 7 13:34:00 GMT 2007


I installed Cygwin on my new machine yesterday and now I cannot start
x as I am used to. A fatal error occurs. I tried to start using
startxserver.bat which uses:

XWin -multiwindow -clipboard -silent-dup-error

Here is the content of the XWin.log:

(WW) /tmp mounted int textmode
_XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix will not be created.
(II) XF86Config is not supported
(II) See for more information
winAdjustVideoModeShadowGDI - Using Windows display depth of 32 bits per pixel
winAllocateFBShadowGDI - Creating DIB with width: 3000 height: 1200 depth: 32
winInitVisualsShadowGDI - Masks 00ff0000 0000ff00 000000ff BPRGB 8 d 24 bpp 32
null screen fn ReparentWindow
null screen fn RestackWindow
InitQueue - Calling pthread_mutex_init
InitQueue - pthread_mutex_init returned
InitQueue - Calling pthread_cond_init
InitQueue - pthread_cond_init returned
winInitMultiWindowWM - Hello
winMultiWindowXMsgProc - Hello
winInitMultiWindowWM - Calling pthread_mutex_lock ()
winMultiWindowXMsgProc - Calling pthread_mutex_lock ()
MIT-SHM extension disabled due to lack of kernel support
XFree86-Bigfont extension local-client optimization disabled due to
lack of shared memory support in the kernel
(--) Setting autorepeat to delay=500, rate=31
(--) winConfigKeyboard - Layout: "00000409" (00000409)
(--) Using preset keyboard for "English (USA)" (409), type "4"
(--) 3 mouse buttons found
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/,
removing from list!

Fatal server error:
could not open default font 'fixed'

I tried to fix the problem according to
but this did not help. Also reinstalling all the fonts did not help.

A mount shows the following:

$ mount
C:\cygwin\bin on /usr/bin type user (textmode)
C:\cygwin\lib on /usr/lib type user (textmode)
C:\cygwin on / type user (textmode)
c: on /cygdrive/c type user (textmode,noumount)
d: on /cygdrive/d type user (textmode,noumount)
h: on /cygdrive/h type user (textmode,noumount)
k: on /cygdrive/k type user (textmode,noumount)
o: on /cygdrive/o type user (textmode,noumount)
s: on /cygdrive/s type user (textmode,noumount)
t: on /cygdrive/t type user (textmode,noumount)
u: on /cygdrive/u type user (textmode,noumount)
x: on /cygdrive/x type user (textmode,noumount)

There is no mount point for /usr/X11R6/lib/X11/fonts....

Any ideas on how to fix this problem?

Thanks a lot in advance!

Best regards,

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list