SSH X11 forwarding issues

Larry Hall (Cygwin X)
Sat Apr 8 17:28:00 GMT 2006

Brett Serkez wrote:
>> ZoneAlarm, but I have the remote PC in my trusted list.  Plus, both
>> Cygwin/X/putty and X-Win32/StarnetSSH work fine, so this seems to be a
>> Cygwin issue...
> The only way I've been able to use either the -X or -Y switches is to
> uninstall ZoneAlarm, shutting it down is insufficient.
> The problem, atleast in my case seems to have something to do with
> xauth getting stuck and never returning, it actually locks up to the
> point of having to shutdown the X server and usually causes Windows to
> hang when trying to logout or reboot.
> This used to work, I have an older system that I use occasionally that
> is running ZoneAlarm and an older version of Cygwin that I can use
> -X/-Y and works great.  I've tried using this as a model to work
> backwards to diagnose with no luck.
> I've tried various times to debug and have given up, I manually set
> the X display variable myself like:
> ssh -R 6010:localhost:6000 target
> then after login:
> export DISPLAY=:10
> Of course the issue is that I'm guessing on the target as to which
> port is open, but so far this has worked for me.

Still sounds like a ZoneAlarm issue.  It's worth another look.

Larry Hall                    
RFK Partners, Inc.                      (508) 893-9779 - RFK Office
838 Washington Street                   (508) 893-9889 - FAX
Holliston, MA 01746

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list