Running Xwin at 100 dpi

Julian Yap
Thu Sep 22 05:43:00 GMT 2005

OK, I answered my own question and found my own answer through more testing.

Modify startxwin.bat.

Use this line to start up Xwin in 100 dpi mode:
run XWin -multiwindow -clipboard -silent-dup-error -dpi 100

Add this line to prepend the font path:
xset +fp /usr/X11R6/lib/X11/fonts/100dpi/

Run your xterm and specify the font parameters.
run xterm -fa "Lucida" -fs 10 -e /usr/bin/bash -l


-----Original Message-----
From: Julian Yap [] 
Sent: Thursday, 22 September 2005 2:05 PM
Subject: Running Xwin at 100 dpi

Hi all,

I run Xwin to start up my xserver and xterm.  This is the script located in
the cygwin install: C:\cygwin\usr\X11R6\bin\startxwin.bat

My Windows installation uses 120 dpi fonts.  Unfortunately, the xterm and
xwindows programs are horrifically small in font.  

I've tried looking everywhere but I can't increase my font size.

These are the current lines in my startxwin.bat of concern:
run XWin -multiwindow -clipboard -silent-dup-error
run xterm -e /usr/bin/bash -l

I have tried starting up Xwin with the following line but it doesn't change
anything: run XWin -multiwindow -clipboard -silent-dup-error -dpi 100

I also tried the following to specify the font path to no avail: run XWin
-fp "/usr/X11R6/lib/X11/fonts/misc/, /usr/X11R6/lib/X11/fonts/TTF/,
/usr/X11R6/lib/X11/fonts/Type1/, /usr/X11R6/lib/X11/fonts/cyrillic/,
/usr/X11R6/lib/X11/fonts/100dpi/, /usr/X11R6/lib/X11/fonts/75dpi/"
-multiwindow -clipboard -silent-dup-error

Also, when I then SSH into a Linux machine, and run programs, like xterm or
gvim, they are still small and not legible.

Can anyone help me run Xserver at 100 dpi?  Or another workaround?


Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list