Soong, SylokeJ
Thu Sep 1 22:29:00 GMT 2005

When I first installed Cygwin/X and tried,
I ran into the same puzzlement, if not panic.

All the xterms and xclock I started were heaped
into the same corner, intransigently unmoveable.
(The sun shall not strike thee, nor the moon by
night and your feet will not be moved, as though).

Then I recalled, hmm ....
There is an X Display Server and then
there is an X Display Manager.
I think. I'm sure I have not confused the

The default as cygwin was installed only started
the X Display server.
An X Display mgr would be prudent to have if I
wanted to have a Motif look or even Win/95 look
and to manage how the window or menus behave.
I guess an XDM would also help with coordinate
placement of apps like xclock and xterms.

So I looked into the startxwin files and was as
assured to find twm (which I guessed correctly is
an X display mgr) commented out.
I uncommented it and when XWin restarted
my xterms and xclock were moveable.

But I didn't like twm because the extremity of my
X habits tends to pile up lots of windows
and would have me a hard time searching for them
without a desktop window locater. Which led me
to install wmaker.

Hey! Why couldn't I throw xterms from my sun box to
local cygwin? My $DISPLAY on sunside was correct.
With all the authentication failures and whatnots.

Oops, I had forgotten to run
xhost +
on the local cygwin xterm.
(I actually made the mistake of attempting xhost +
on an XP cmd window prior to that.)
"xhost +" or
"xhost + some-network-identifiable-hostname."

The installation was rather simple that
everyone around my periphery of physical influence
should be able use cygwin to replace their branded
X display s/w. 

Now I am beginning to wonder, what if I just started
the X display server on local cygwin and then attempt
to throw an X display mgr to it from my sun box?
Or get a little more screwy,
start x server on my laptop cygwin,
throw wmaker from my win2k box to my laptop,
login to sun box and throw xterms to my laptop.

hmm.... looking on the sunnyside of things,
but I can't wait for the snow to fall.

-----Original Message-----
Sent: Thu, September 01, 2005 4:55 PM
Subject: problem

I have installed cygwin and everything seems to run smoothly except I 
can't get any display to work.  If I execute XWin then it opens up a 
grey window with an "X" at the top followed by "Cygwin/X-0:0" and 
that's it.  There's no menu options or anything.  If i do "XWin -query 
remote_host" then the same thing comes up with "Cygwin/X-
If I connect with "ssh -Y remote_host" it connects me but if i try to 
execute something that requires a display...such as "xeyes"...Then it 
says "connect port 6000: Connection refused/ Xconnection to 
localhost:12.0 broken (explicit kill or server shutdown)"

So i don't know what I'm doing wrong.

Thanks a lot,
-Richard Hildner 

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list