FTP and xterm in 1.5.16...

Randy Widell randy@slakr.org
Mon May 16 21:51:00 GMT 2005

> -----Original Message-----
> From: cygwin-xfree-owner@cygwin.com 
> [mailto:cygwin-xfree-owner@cygwin.com] On Behalf Of Cary Jamison
> Sent: Monday, May 16, 2005 17:18
> To: cygwin-xfree@cygwin.com
> Subject: Re: FTP and xterm in 1.5.16...
> Randy Widell wrote:
> > After upgrading to 1.5.16, Cygwin seems to just hang when 
> using 'ftp'
> > in xterm.  Oddly enough, the problem does not occur when running a 
> > shell through the Windows command window instead of xterm.
> Are you sure this is a new behavior?  Were you previously 
> using cygwin's ftp and are now using MS's?
> Many window's programs don't work properly through cygwin's 
> ptys.  The result can be that the process seems to just hang 
> when it should be prompting for input.
> Cary

Now that you mention it, I must be running MS's ftp.  This is a new
behavior, though (not necessary a bad one now that I know I was using MS's
ftp).  I have used ftp through xterm many many times in the past, and tried
to ftp into GNU.org literally right after finishing installing Cygwin
updates (unfortunately, I cannot remember all of the packages I
downloaded...there may have been some X packages).

Anyway, I tried installing ncftp to make sure I am not using MS's ftp and
all seems well again.

Thanks for the help.

More information about the Cygwin-xfree mailing list