rdesktop build on cygwin gone wrong

David Rothenberger daveroth@acm.org
Thu May 12 00:00:00 GMT 2005

On 5/11/2005 4:07 PM, jose isaias cabrera wrote:
> Sorry for the cross-post, but...
> Ok, so I downloaded rdesktop 1.4.1 to build it with cygwin on a WinXP 
> Pro machine.  And on the "make install", I am getting this error:
> jic 16:32:18-> make install
> mkdir -p /usr/local/bin
> /usr/bin/install -c rdesktop /usr/local/bin
> strip /usr/local/bin/rdesktop
> strip: /usr/local/bin/rdesktop: No such file or directory
> make: *** [installbin] Error 1
> I've tried it a few times and I still get the the same problem.  Here is 
> the interesting part: rdesktop works and the man page also.  Huh!
> Any ideas?

It's because the makefile really needs to invoke "strip 
/usr/local/bin/rdesktop.exe" Strip just removes any debugging symbols, 
so the executable without the strip will work fine, it just might be 
larger than you need.

To fix the problem, you can apply the supplied patch, or just run "strip 

David Rothenberger                spammer? -> spam@daveroth.dyndns.org
GPG/PGP: 0x7F67E734, C233 365A 25EF 2C5F C8E1 43DF B44F BA26 7F67 E734

I don't think it's worth washing hogs over.
              -- Larry Wall in <199710060253.TAA09723@wall.org>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: rdesktop-1.4.1.patch
URL: <http://cygwin.com/pipermail/cygwin-xfree/attachments/20050512/5e8c7452/attachment.ksh>

More information about the Cygwin-xfree mailing list