Can't launch an xterm under windows xp-pro

René Berber
Wed Dec 28 04:54:00 GMT 2005

Greg Moore wrote:
> I'm having trouble launching an xterm (indeed, any windows manager)
> under windows xp-"professional" and am hoping for even the smallest
> clues as to where I might go next.

Xterm is not a window manager.

> startwinx.bat produces only the message, "startxwin.bat - Starting
> on Windows NT/200/XP/2003"
> Other than an xserver icon in the taskbar ("Cygwin/X Server - 0:0"),
> nothing else seems to happen.

Have you tried to open the Xterm after running startxwin.bat?

How are you running Xterm?  From the start -> Programs -> Cygwin-X menu?

> After consulting the cygwin-x-ug, the cygwin-x-faq, and searching
> the archives I've tried the following, and all combinations thereof:
> 1. launching the xserver and a windows manager separately.  "xwin"
> does produce a fullscreen server window, but it's transparent and,
> though it can be minimised, just then sits in the taskbar.  The
> other window managers I've tried (twm, openbox) exhibit the same
> behaviour as xterm; though they show up as running processes,
> nothing is displayed.
> 2. checked /etc/hosts/ to ensure that localhost is indeed
> 3. made sure /tmp is in binmode
> 4. not running Zone Alarm
> 4. disabled all McAfee SecurityCenter "features"
> Any advice or leads very much appreciated.
> Best regards,

In your home directory, do you have a .xinitrc?

If nothing works you should look into the log produced by Xwin, it's in

René Berber

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list