Problem with numerical input for certain applications in Cygwin

scott Langford
Tue Dec 6 18:34:00 GMT 2005

-----Original Message-----
From: Igor Pechtchanski [] 
Sent: Monday, December 05, 2005 7:26 PM
To: scott Langford
Subject: Re: Problem with numerical input for certain applications in

On Mon, 5 Dec 2005, scott Langford wrote:

> I am running Cygwin to ssh onto a Linux server which handles a couple
> applications that I use for design work. When I run the applications
> there are various fill forms which require numeric entry. For some
> reason I cannot make any numeric input into these forms. The same
> have character entry which works fine. I tried the FAQ and users Guide
> but could not find any examples of this exact problem. I have some
> support but that person was basically at a loss. I am not sure where
> look to correct this problem. When I run directly on my Linux server I
> do not have this problem. I suspect there is some setup in my
> file that may help. Any suggestions?

You haven't specified exactly *how* you invoke the applications on
but I suspect they are X applications and you invoke them via the X
forwarding feature of ssh.  This makes your question off-topic for the
main list, and on-topic for the cygwin-xfree list (which the Reply-To of
this message points to).  If you aren't using X, please follow-up to the
main list with more details.

As for your problem, in the absense of more information, it looks like
you're seeing weird Num-Lock-related behavior, which is a known problem
with Cygwin/X.  Try using the digits above the alphabetical keys instead
of the keypad.  I also seem to recall some recipes for making Num-Lock
work properly -- searching the cygwin-xfree archives may help.
> Thank you for your reply. Indeed I am using the X forwarding features
> ssh. I read somewhere (in my many searches) that there could be some
> hardware related issues to the num-lock, so I will follow that thread.
> Unfortunately, I am trying to use the digits above the alphabetical
> instead of the keypad (but I think it was a good suggestion). Thanks
> your help and sorry for the post to the wrong mailing list.
> Scott Langford


Another thing to check is whether you're hitting the limitations of
untrusted X forwarding (see the Cygwin/X FAQ entry on ssh).  Also, does
this problem occur only in those applications, or in any X application
(e.g., an xterm)?  If the latter, you may have keyboard mapping issues
the output from pressing those keys in xev might help.  If the former,
eliminating ssh as the culprit (e.g., temporarily opening up the local X
server with "xhost +" and setting the DISPLAY on the remote machine to
connect directly to the local server).

It would also help to know what you use to start your local X (there is
such thing as -- there's "", "startxwin.bat", or
"startx").  Do you have a ~/.Xserverrc?  What window manager are you
      |\      _,,,---,,_
ZZZzz /,`.-'`'    -.  ;-;;,_
     |,4-  ) )-,_. ,\ (  `'-'		Igor Pechtchanski, Ph.D.
    '---''(_/--'  `-'\_) fL	a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!

If there's any real truth it's that the entire multidimensional infinity
of the Universe is almost certainly being run by a bunch of maniacs. /DA


I am using the -Y option so I do not think it is a limitation of
untrusted forwarding. The problem does not occur in xterm or konsole
applications. It only seems to occur in two design applications I have
tried: Cadence IC works and Slam edit.  
You are correct there is no  I am using here. I
am using the following command lines:
XWin -multiwindow -clipboard -silent-dup-error -multimonitors
-emulate3buttons 100 &

xterm -sl 1000 -sb -rightbar -ms red -fg yellow -bg black -e
/usr/bin/bash -l &

In this case, I am using the integrated windows based windows manager. I
do not have a ~/.Xserverrc. I have considered trying the twm option. I
will try to rule out ssh. Thanks for your help.

Scott Langford 

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list