Problem with numerical input for certain applications in Cygwin

Igor Pechtchanski
Tue Dec 6 00:25:00 GMT 2005

On Mon, 5 Dec 2005, scott Langford wrote:

> I am running Cygwin to ssh onto a Linux server which handles a couple of
> applications that I use for design work. When I run the applications
> there are various fill forms which require numeric entry. For some
> reason I cannot make any numeric input into these forms. The same forms
> have character entry which works fine. I tried the FAQ and users Guide
> but could not find any examples of this exact problem. I have some Linux
> support but that person was basically at a loss. I am not sure where to
> look to correct this problem. When I run directly on my Linux server I
> do not have this problem. I suspect there is some setup in my
> file that may help. Any suggestions?

You haven't specified exactly *how* you invoke the applications on Linux,
but I suspect they are X applications and you invoke them via the X
forwarding feature of ssh.  This makes your question off-topic for the
main list, and on-topic for the cygwin-xfree list (which the Reply-To of
this message points to).  If you aren't using X, please follow-up to the
main list with more details.

As for your problem, in the absense of more information, it looks like
you're seeing weird Num-Lock-related behavior, which is a known problem
with Cygwin/X.  Try using the digits above the alphabetical keys instead
of the keypad.  I also seem to recall some recipes for making Num-Lock
work properly -- searching the cygwin-xfree archives may help.
      |\      _,,,---,,_
ZZZzz /,`.-'`'    -.  ;-;;,_
     |,4-  ) )-,_. ,\ (  `'-'		Igor Pechtchanski, Ph.D.
    '---''(_/--'  `-'\_) fL	a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!

If there's any real truth it's that the entire multidimensional infinity
of the Universe is almost certainly being run by a bunch of maniacs. /DA

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list