Is Cygwin/X compatible with HP's mwm?

Soong, SylokeJ
Thu Dec 1 19:28:00 GMT 2005

Did you start cygwin/x xdm and then attempted to run remote host's
mwm on it?

What about going thro xdmcp?

I have always run cygwin/x using both its xdm and xwm on the
same machine.
I have never tried running cygwin/x xdm and then running remote
Solaris or HPUX mwm on it. Is that possible?
Could I also deploy cygwin/x multiwindow and then attempt to throw
remote mwm on it?

Is going thro the remote xdmcp the only way to use remote xwm?

Presuming my terminology is correct:...
xdm - x display mgr to set up the x display
xwm - x win mgr runs on top of xdm,
  to manage the willy nilly remote windows,
  without which those windows will pile up
  on one corner of the local xdm.
mwm - motif based xwm.

-----Original Message-----
[]On Behalf Of
Sent: Thu, December 01, 2005 9:25 AM
Subject: Is Cygwin/X compatible with HP's mwm?

Is Cygwin/X compatible with the mwm (Motif Window Manager) that comes 
with HPUX 10.20?  Or is Cygwin/X only supposed to work  with Linux? I 
have an application that works fine with Redhat's X server, Exceed, and 
Reflections, but not Cygwin/X.  I was hoping to use Cygwin/X instead of 
the commercial X servers. But Cygwin/X doesn't communicate with mwm. 
I've been trying for days but it's just not working. Application 
windows all appear normal in Cygwin/X but there is no interaction with 
the window manager. For example,  I can't move windows on the screen. 
The last window created is the only one that gets "focus". Clicking on 
the others does nothing. Window manager pull down menus don't display. 
In short, there is no interaction at all between Cygwin/X and the mwm 
window manager. Is anyone out there using Cygwin/X successfully in this 
environment? Does anyone know if Cygwin/X has been tested with HP's 
mwm? I also tried the twm window manager that comes with HPUX 10.20.  
Is doesn't work right either. The problems are similar but not exactly 
the same. In the case of twm an outline of the last window created is 
attached to the mouse pointer. Clicking on the desktop causes the 
window to be completed and appear normal.  I am able to interact with 
the window manager after that. But what's going on with this weird 

Try the New Netscape Mail Today!
Virtually Spam-Free | More Storage | Import Your Contact List

Unsubscribe info:
Problem reports:

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list