Java GUI unable to correctly detect keystrokes

Neil Mc Laughlin
Wed Oct 20 10:58:00 GMT 2004

Since upgrading to the latest Cygwin X-Server, Java GUIs are unable to
correctly detect keystrokes while an Xterm appears to work correctly. In
fact, the GUI seems to think the Alt key is being held down when the key is
pressed. This worked fine with the previous (unknown) version of Cygwin.

The Cygwin platform is Windows XP Professional V 2002 with service pack 2
installed. XWin release is

java version "1.2.2"
Solaris VM (build Solaris_JDK_1.2.2_10, native threads, sunwjit)

The problem occurs when trying to display a remote Java application running
on a Solaris 8 system. I've tried a few Java applications on a few different
Solaris boxes with the same results on each occasion.

In addition the X connection is being tunneled via ssh, with openssh running
on the Solaris Systems. I've tried tunneling with both Putty and Cygwin Ssh
on the windows platform. In each case, the Java application failed to detect
keystrokes while the Xterm worked successfully. Due to firewall restrictions
at this site, I am unable to test a direct X connection.

I've only just discovered SP 2 has been installed on the box - against my
better judgement - probably by Microsoft Update, and probably around the
time we started to have problems. This upgrade was triggered by a failure in
the X Server, which was put down to the removal of spyware from the box. My
initial suspicion was that this is a Java issue with this version of cygwin.
Now I'm wondering if it might be an XP Service Pack 2 issue.

Can anyone help or advise here?

Neil McLaughlin

More information about the Cygwin-xfree mailing list