XWin startup problem

Simon Marchese simon_marchese@uk.ibm.com
Mon Oct 18 18:32:00 GMT 2004

On Mon, 18 Oct 2004, Simon Marchese wrote:

>> I can't start XWin successfully on WinXP. I have re-installed and re-booted so often that I'm wearing out my disk and the restart icon. Yes, I have tried the advice in http://x.cygwin.com/docs/faq/cygwin-x-faq.html#q-error-font-eof and it has not helped.
>> I would be very grateful for any advice. I have included more information below. Please let me know if there is anything I can add.

>please try removing 

>rm /usr/X11R6/lib/X11/fonts/misc/fonts.dir

>this should not print the uptodate line for /usr/X11R6/lib/X11/fonts/misc

Yup, it didn't print the uptodate line but XWin emits the same errors.

Ok, so I started to relearn Xserver stuff. I found that I can start "xfs" separately to XWin and use "xfsinfo" to see if it's working and "xlsfonts" to see what it's capable of supplying. Now, in /usr/X11R6/lib/X11/fonts/misc/fonts.alias, the line containing "fixed" is the following:

fixed        -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-1

However, if I run "fslsfonts -server localhost:7100" then I get that font listed. So, not having seen a working one of these for a while, I'm not sure whether XWin even starts a font server. If not, where does XWin go for fonts? So, I download the source, and find that there appears to be a default like this.

/usr/src/xc/programs/Xserver/include/site.h:#define COMPILEDDEFAULTFONTPATH"/usr/lib/X11/fonts/misc/"

So I check /usr/lib/X11/fonts/misc, and that turns out ok:

$ ls -l /usr/lib/X11
lrwxrwxrwx    1 simon    Users          16 Oct 18 03:23 /usr/lib/X11 -> ../X11R6/lib/X11

Which still leaves me with the problem. Any suggestions?

More information about the Cygwin-xfree mailing list