Tunneling does not seem to work here (newbie)?

savantsaro@cox.net savantsaro@cox.net
Thu Oct 14 12:46:00 GMT 2004

>> box 1: Windows 2000 Server
>>        cygwin
>> box 2: Mac OS X 10.3 (Panther)
>> cygwin was installed with openssh, today, from the latest setup.exe.

>FYI, it's probably a good idea to review ><http://cygwin.com/problems.html>
>before sending bug reports...  Reading
>/usr/share/doc/Cygwin/openssh.README would also help.

I did read the first one, wasn't aware of the second one. I spent several hours researching and trying to solve the problem before posting here.

Also, I'm not implying it's a bug - I'm sure there's something I missed, I just can't figure out what it is.

>> Basic scenario:
>> startxwin.bat -> X icon appears in taskbar, terminal opens
>> ssh -Y -l username box2name -> ssh connection is established and works fine
>> emacs & -> [1]+ Stopped      emacs
>> Troubleshooting already done:
>> I have also tried with putty, with X11 tunneling enabled, and tried
>> running other apps (specifically a java swing application, which does
>> not stop but simply does nothing on box 1)
>> The DISPLAY environment variable was not set.

>There's your problem.  You should set it before >running "ssh -Y".  For example try either
>export DISPLAY=:0.0; ssh -Y username@boxname
>or even
>DISPLAY=:0.0 ssh -Y username@boxname
>-- both should work.

I did set DISPLAY before running ssh, before I posted here.

I just tried your examples, but still get the same result.

>> I tried setting it to "localhost:0.0" and to ":0", with no effect.
>> The config files for ssh (~/.ssh/config and /etc/ssh_config) did not
>> exist.

>Ah.  Did you run /bin/ssh-user-config?

No, I wasn't aware of it.

I have run it now, created all the identities and used none of them. Still no change.

>> I created the first one with a single line (ForwardX11 yes) with no
>> change.
>> Please help. I know cygwin is a good, working program, and I'm an
>> intelligent computer guy - why won't it work for me?

>Maybe Cygwin just doesn't like you? ;-)

The thought had occurred to me.

More information about the Cygwin-xfree mailing list