Tunneling does not seem to work here (newbie)?

Igor Pechtchanski pechtcha@cs.nyu.edu
Wed Oct 13 21:31:00 GMT 2004

On Wed, 13 Oct 2004, savantsaro wrote:

> box 1: Windows 2000 Server
>        cygwin
> box 2: Mac OS X 10.3 (Panther)
> cygwin was installed with openssh, today, from the latest setup.exe.

FYI, it's probably a good idea to review <http://cygwin.com/problems.html>
before sending bug reports...  Reading
/usr/share/doc/Cygwin/openssh.README would also help.

> Basic scenario:
> startxwin.bat -> X icon appears in taskbar, terminal opens
> ssh -Y -l username box2name -> ssh connection is established and works fine
> emacs & -> [1]+ Stopped      emacs
> Troubleshooting already done:
> I have also tried with putty, with X11 tunneling enabled, and tried
> running other apps (specifically a java swing application, which does
> not stop but simply does nothing on box 1)
> The DISPLAY environment variable was not set.

There's your problem.  You should set it before running "ssh -Y".  For
example try either

export DISPLAY=:0.0; ssh -Y username@boxname

or even

DISPLAY=:0.0 ssh -Y username@boxname

-- both should work.

> I tried setting it to "localhost:0.0" and to ":0", with no effect.
> The config files for ssh (~/.ssh/config and /etc/ssh_config) did not
> exist.

Ah.  Did you run /bin/ssh-user-config?

> I created the first one with a single line (ForwardX11 yes) with no
> change.
> Please help. I know cygwin is a good, working program, and I'm an
> intelligent computer guy - why won't it work for me?

Maybe Cygwin just doesn't like you? ;-)
You know, <http://cygwin.com/acronyms/#WJM>...
      |\      _,,,---,,_		pechtcha@cs.nyu.edu
ZZZzz /,`.-'`'    -.  ;-;;,_		igor@watson.ibm.com
     |,4-  ) )-,_. ,\ (  `'-'		Igor Pechtchanski, Ph.D.
    '---''(_/--'  `-'\_) fL	a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!

"Happiness lies in being privileged to work hard for long hours in doing
whatever you think is worth doing."  -- Dr. Jubal Harshaw

More information about the Cygwin-xfree mailing list