Tunneling does not seem to work here (newbie)?

savantsaro@cox.net savantsaro@cox.net
Wed Oct 13 19:36:00 GMT 2004

box 1: Windows 2000 Server

box 2: Mac OS X 10.3 (Panther)

cygwin was installed with openssh, today, from the latest setup.exe.

Basic scenario:
startxwin.bat -> X icon appears in taskbar, terminal opens
ssh -Y -l username box2name -> ssh connection is established and works fine
emacs & -> [1]+ Stopped      emacs

Troubleshooting already done:
I have also tried with putty, with X11 tunneling enabled, and tried running other apps (specifically a java swing application, which does not stop but simply does nothing on box 1)
The DISPLAY environment variable was not set. I tried setting it to "localhost:0.0" and to ":0", with no effect.
The config files for ssh (~/.ssh/config and /etc/ssh_config) did not exist. I created the first one with a single line (ForwardX11 yes) with no change.

Please help. I know cygwin is a good, working program, and I'm an intelligent computer guy - why won't it work for me?

Replies welcome on this list or directed to me : savantsaroATcoxDOTnet

More information about the Cygwin-xfree mailing list