three button emulation (not a faq, honestly)

Phillip Lord
Thu Oct 7 10:51:00 GMT 2004

I've been having a nightmare getting cut and paste working properly
with cygwin-x. I went through the faqs, I various things, and
eventually isolated the problem to three button emulation on the

So I read up on this. I'm using multiwindow, so I can't use
emulate3button. I tried using tweak UI as suggested in the faq, but
for the life of me I can't find anything relating to three button
emulation in tweakUI. 

Finally, I tried using an external USB mouse (this is on a laptop). And it
all just works. So I think that the problem is with the mouse pad
driver. It enables me to fiddle with the button settings. I think it's
intercepting the double mouse click, so cygwin is not getting it. 

So two questions

1) Has anyone else had the same problem? Has any one else managed to
   solve the problem? 

2) If I can't solve the problem, is there any way of accessing paste
   functionality in a bash shell with the keyboard (short of running
   it in emacs!)? Can I bind one of the function keys to paste for



More information about the Cygwin-xfree mailing list