Solaris X app crashes with Cygwin/X

Maarten Boekhold
Wed Oct 6 04:08:00 GMT 2004


if this is because of missing fonts, why does it work when I run it from 
a CDE session started with XWin :1 -query remotehost? Doesn't is still 
use the fonts that are local to the X-Server?

eg. If I run the app as described above,I do not expect it to get its 
fonts from the Solaris box, I expect it to still use the fonts that are 
on my cygwin machine.


Alexander Gottwald wrote:
> On Mon, 27 Sep 2004, Maarten Boekhold wrote:
>>I've got an application that runs on Solaris, and ever since the upgrade 
>>to X.Org 6.8.0 (now 6.8.1), it crashes if I try to start it. The weird 
>>thing is, that if I do 'XWin :1 -query remotehost' and start the app in 
>>that screen, it runs fine. I.e. under the CDE environment there's no 
>>Does anybody have any hints on how to debug this?
>>I'm running a locally compiled version of openbox as window manager (on 
>>:0.0). I'll see if recompiling that helps (tomorrow though).
> Most likely this is because of missing fonts. Some Solris tools do not check
> if the queried font was found, they simply assume it is there and run into 
> a null pointer. 
> Check the FAQ about Solaris and fonts. The method of setting the font path 
> does apply to this condition too.
> bye
> 	ago

More information about the Cygwin-xfree mailing list