ssh, xwindows.

Jonathan Gemmell
Fri Jun 4 20:31:00 GMT 2004


Thanks in advance for your help!

I am trying to ssh into another computer with the -X option from a windows 
machine running cygqin.

I am following this procedure

export DISPLAY="ipaddress"
openbox.exe &
ssh -X "computer"

However, when I run the x& line, I run into trouble.  I get the fram of the 
window, but nothing else, and I get the following errors...

$ x&
[1] 3772

Jonathan F. Gemmell@DGBQGX21 ~
$ Welcome to the XWin X Server
Vendor: The Cygwin/X Project


winInitializeDefaultScreens - w 1024 h 768
winInitializeDefaultScreens - Returning
_XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
XWin was started with the following command line:


winValidateArgs - g_iNumScreens: 1 iMaxConsecutiveScreen: 1
(II) XF86Config is not supported
(II) See for more information
winDetectSupportedEngines - Windows NT/2000/XP
winDetectSupportedEngines - DirectDraw installed
winDetectSupportedEngines - DirectDraw4 installed
winDetectSupportedEngines - Returning, supported engines 00000007
winSetEngine - Using Shadow DirectDraw NonLocking
winAdjustVideoModeShadowDDNL - Using Windows display depth of 32 bits per 
winFinishScreenInitFB - Masks: 00ff0000 0000ff00 000000ff
MIT-SHM extension disabled due to lack of kernel support
XFree86-Bigfont extension local-client optimization disabled due to lack of 
(--) Setting autorepeat to delay=500, rate=31
(--) winConfigKeyboard - Layout: "00000409" (00000409)
(EE) Keyboardlayout "US" (00000409) is unknown
Rules = "xorg" Model = "pc101" Layout = "us" Variant = "(null)" Options = 
bash: l: command not found
[1]+  Done                    x

Thanks again for your help!

Jon Gemmell

Get fast, reliable Internet access with MSN 9 Dial-up – now 3 months FREE!

More information about the Cygwin-xfree mailing list