new install - application windows are dead

Gareth Edwards
Mon Jul 26 21:32:00 GMT 2004

Hi there,

I've been happily using Cygwin/X for a couple of years on 2 or 3 
different PC systems primarily as a display server for some Big Iron in 
our server room.

I've recently installed Cygwin/X on my new whizz-bang desktop machine 
and I'm having a problem. When I run (or startxwin.bat for 
that matter) everything appears to come up normally, with the exception 
of anything in the window itself.

For example, the xterm in the default startup script stays as a white 
window with no prompt or text, and the mouse cursor is 'X' when it is 
over this window. In this case, the window titlebar changes to '~' which 
implies that bash has started to run OK (indeed, Windows task manager 
shows bash.exe exists) but I don't know why it's not painting properly 
or handling events.

As a second example, xlogo again creates a white window with no 
contents. Again, the mouse cursor is 'X' when I hover on the window.

Launching the client program on the remote solaris box with approriate 
DISPLAY set has the same result; a window appears but it stays empty.

Nothing I can get from XWin.log but I've attached it regardless.

Hope someone can help!


-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: XWin.log
URL: <>

More information about the Cygwin-xfree mailing list