XFree86-xserv-4.3.0-47 copy/paste trouble and BadAtom.

Keith Thompson kst@mib.org
Fri Feb 27 20:39:00 GMT 2004

On Thu, Feb 26, 2004 at 03:00:42PM -0500, Igor Pechtchanski wrote:
> On Thu, 26 Feb 2004, Keith Thompson wrote:
> > It looks like the problem has to do with the new OpenSSH package.
> >
> > I tried logging into my Solaris box using SecureCRT, a Windows SSH client,
> > and then starting up an xterm from there; cut-and-paste worked correctly.
> >
> > Now I've re-upgraded all the XFree86 packages and downgraded OpenSSH to
> > OpenSSH_3.7.1p2, and cut-and-paste still works correctly.
> >
> > It looks like there's a problem with X forwarding in the new OpenSSH
> > package.
> >From the new OpenSSH-3.8p1-1 announcement:
> * ssh(1) now uses untrusted cookies for X11-Forwarding.
>   Some X11 applications might need full access to the X11 server,
>   see ForwardX11Trusted in ssh(1) and xauth(1) for more information.

Thanks.  Adding
    ForwardX11Trusted yes
to my $HOME/.ssh/config did the trick.

(Oddly, I never saw the problem on my Windows 2000 system, only on
Windows XP.)

Keith Thompson (The_Other_Keith) kst@mib.org  <http://www.ghoti.net/~kst>
San Diego Supercomputer Center           <*>  <http://www.sdsc.edu/~kst>
Schroedinger does Shakespeare: "To be *and* not to be"

More information about the Cygwin-xfree mailing list