XFree86-xserv-4.3.0-47 copy/paste trouble and BadAtom.

Keith Thompson kst@mib.org
Thu Feb 26 17:34:00 GMT 2004

In my previous message, I missed a major piece of the puzzle.

The xterm windows that are dying mysteriously are running on a Solaris
system, not on my laptop under Cygwin.

Here's the scenario.  My laptop is "baldur" (IBM Thinkpad T40, Windows
XP, Cygwin); my Sun workstation is "elmak" (Sun Blade 100, Solaris 8).

On Baldur, I run the Hummingbird Exceed version 7 X server and the fvwm2
window manager (neither of which seems to be relevant).  From an xterm
window on baldur, I run

    xterm -e ssh elmak &

This gives me a shell on elmak running in an xterm window on baldur.
With OpenSSH X11 forwarding, I have $DISPLAY set to 'elmak:7.0'.

On elmak, I run

    xterm &

Now I have a second shell on elmak, this one in an xterm window running
on elmak but displayed on baldur.  No further forwarding is needed,
so the new shell also has $DISPLAY set to 'elmak:7.0'.

I can run X clients, such as xlogo, from any of these three windows,
and they display properly.

In the first two xterm windows, I can cut-and-paste.  In the third (the
Solaris xterm), if I try to highlight a region of text, the xterm dies
as soon as I release the mouse button, and the parent window gets:

xterm:  warning, error event receieved:
X Error of failed request:  BadAtom (invalid Atom parameter)
  Major opcode of failed request:  18 (X_ChangeProperty)
  Atom id in failed request:  0xb6
  Serial number of failed request:  277
  Current serial number in output stream:  279

This problem first showed up in the last few days, when I updated a
bunch of XFree86 packages through the Cygwin setup utility.

This isn't specific to Solaris.  I get the same symptom with an
xterm running on a variety of systems, including Red Hat with
XFree86-4.3.0-2.90.55, AIX, and SunOS 4.1.3 with X11R6.3.

Keith Thompson (The_Other_Keith) kst@mib.org  <http://www.ghoti.net/~kst>
San Diego Supercomputer Center           <*>  <http://www.sdsc.edu/~kst>
Schroedinger does Shakespeare: "To be *and* not to be"

More information about the Cygwin-xfree mailing list