MultiWindow Mode: stty speed = 0 on xterm cause rlogin to fail

Danilo Turina
Wed Feb 25 10:25:00 GMT 2004

Hello everybody,
	it's some time I'm using Cygwin and XFree and I feel very satisfied 
with both them.

Until today, I always have used the rootless mode + wmaker (which I like 
very much). Anyway this morning I tried to switch to the multiwindow mode.

Having customized the "contextual" menu of wmaker, I wished to port 
those menu items into the XWin menu modifying .XWinrc.

I have unable to do that, because most of those menu items are xterms 
that rlogins toward HP-UX machines, and they do not work anymore into 
multiwindow mode.

The problem seems related to the stty speed parameter.

In effect opening an xterm within rootless mode I can see from stty that 
the terminal speed is 38400, while opening the same terminal from 
multiwindow mode I see that the speed is 0 (the same does not happens 
for rxvt for which stty always reports 38400).

Searching Google I found that Speed == 0 means "hang up" for some 
machines (e.g. Sun or HP-UX). A solution suggested by this Google search 
was to modify /etc/profile adding something like that:

	if [ -n "$DISPLAY" -a "$TERM" = xterm ] ; then
		stty 38400

In effect this modification solves the problem for rlogins launched 
manually by an xterm, but I does not affect at all commands inserted 
into .XWinrc (they look like "xterm -e rlogin machine -l user").

I tried several ways to put the speed to 38400 for those menu entries 
but I have always failed.

Is there a way to do that?



Danilo Turina
Alcatel Optics OND Network Management
Rieti (Italy) - Phone: +39 0746 600332

2 anni 10 mesi 16 giorni 1 ora 1 minuto 7 secondi

More information about the Cygwin-xfree mailing list