Fw: openGL problem in cygwin-xfree?

Gene C. Ruzicka gcruzicka@comcast.net
Thu Dec 30 11:06:00 GMT 2004

First, I hope I've directed this question to the correct
mailing list: I'm not sure if it's pertinent to this list
or to the cygwin list.

I frequently use cygwin-xfree to log onto external
host machines, usually Solaris or SGI-based. 
This environment worked quite well for me
until recently, when I updated my Cygwin
installation. Ever since then, it appears, that none
of the openGL applications running on the host 
machine have been able to access openGL in the 
cygwin-xfree server.  For example, here is the
error message I get from an application based on
TCL/TK scripting, which interfaces with openGL
using the togl package:

Togl: couldn't get visual while executing 
"togl $dw -width $wwidth -height $wheight -rgba true -double true
   -depth true -ident Box2 -overlay true"

Apparently, the TCL/TK application can't locate the openGL 
facility, anywhere. Another application, the CFD visualization
software FIELDVIEW, does not work when openGL graphics
are specified specified, but works fine when X-based graphics are

Has anyone experienced anything like this recently, and/or
can they assist in finding this problem?  I've attached the
cygcheck output, and I've tried re-installing the openGL 
libary, with no success.  I'm contemplating simply 
reinstalling all of cygwin-xfree, if worse comes to worse. 

Thanx in advance for any help. The cygcheck output is 

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: cygcheck.txt
URL: <http://cygwin.com/pipermail/cygwin-xfree/attachments/20041230/d50c7e3a/attachment.txt>

More information about the Cygwin-xfree mailing list