Duplicate invocation problem with xwin.exe

Martin Gill martin@martinsgill.co.uk
Thu Dec 9 00:55:00 GMT 2004

Ok, managed to find out what the problem was.

Seems it's Zone Alarm. I had to completely uninstall it to solve the

Just thought I'd post this in case anyone else ever has the same problems.

I've sent a note to ZA support... if they offer a solution i'll post it


Martin Gill wrote:
> Hi,
> I just insalled cygwin on my PC, and tried to get the x windows server 
> running.
> I used the startxwin.bat script to do this, but nothing seemed to happen.
> After some investigation, I noticed that I had two xwin.exe processes 
> running. I killed both of them and tried again. Again.. 2 xwin.exe 
> processes started up.
> I checked through the batch file, but all it was doing was starting xwin 
> and then starting xterm. I commented out xterm, just in case and tried 
> again. same result.
> If I run the batch file, I always get 2 xwin.exe processes. I've tried 
> runnig it from cmd as well as from the bash shell, but even in those 
> cases I get 2 processes.
> If i go into task manager and kill the xwin process with the lower 
> memory foot-print, the x-server springs into life and everything works 
> as expected.
> I'm completely confused as to why this is happening.
> My startxwin.bat is unchanged. I'm running WinXP Pro SP2 with the latest 
> stable versions of cygwin.
> Anyone able to offer any suggestions?
> Thanks,
> Martin

More information about the Cygwin-xfree mailing list