Problems building X/Cygwin (no XpConfig)

Igor Shmukler
Wed Dec 1 15:13:00 GMT 2004


I actually went to and got latest release of X.
IMHO, cygwin documentation sucks. Same goes for the setup tool and packaging. At least DLL still works. If maintainers (are there such individuals?) want to know how these things can be done, I suggest looking at FreeBSD ports.

Building an entire environment from scratch is way easier. UWIN that I used several years ago, is nice but not free for commercial use. If you do not need to bother with commercial use I suggest trying UWIN ASAP.


-----Original Message-----
From: Alexander Gottwald <>
To:, Igor Shmukler <>
Date: Wed, 1 Dec 2004 01:43:22 +0100 (MET)
Subject: Re: Problems building X/Cygwin (no XpConfig)

> Igor Shmukler wrote:
> > Hello,
> >
> > I am trying to build X/Cygwin.
> > I installed the tools and used setup program to checkout the sources.
> > For some reason programs/Xserver/ directory does not have XpConfig branch.
> > I tried checking out from several alternative locations.
> > Build compains that the directory is missing and stops. repository indeed does have the directory.
> >
> > Any ideas?
> have you tried cvs update -d? This creates missing directories.
> Which command did you use?
> bye
>         ago
> NP: Iris - Whatever
> -- 
>           ICQ: 126018723

More information about the Cygwin-xfree mailing list