Problem with X forwarding by openssh-3.8p1
Wed Apr 14 22:11:00 GMT 2004

Thank you for the reply. I tried the -Y parameter to ssh and it does solve the
Matlab and ical problems. I am ignorant on the intracacies of Trusted versus
non-Trusted X-forwarding. The FAQ reference by Harold mentions that -Y disables

trusted X-forwarding. So it would seem that for some programs such as Matlab or
ical, trusted X-forwarding will prevent them from being displayed correctly on
cygwin, while other programs such as netscape, gv, or xdvi are fine with
trusted X-forwarding. Is this the correct interpretation?

Alexander Gottwald wrote:

On Wed, 14 Apr 2004 wrote:

> The problem is not that there is no X11-forwarding.

Are you sure? Have you tried the -Y parameter to ssh?

> For example, gv from the
> Linux remote host produces the correct display on the cygwin X-server.
> Similarly, xdvi and even netscape also work. However, if I try to run ical, a
> linux calendar program, I get the following error message:
> X Error of failed request:  BadAtom (invalid Atom parameter)
>   Major opcode of failed request:  18 (X_ChangeProperty)
>   Atom id in failed request:  0x105
>   Serial number of failed request:  13
>   Current serial number in output stream:  16

This is a typical error for the TrustedX11Forward problem.

--           ICQ: 126018723

This message was sent using IMP, the Internet Messaging Program.

More information about the Cygwin-xfree mailing list