Problem with truetype fonts caused by not building FreeType module?

Lev S Bishop
Thu Apr 8 11:58:00 GMT 2004

(Replying to my own message)

I messed about with the and got it to sort of work. My is:

#define BuildFreeType                   YES
#define BuildServersOnly                YES
#define XnestServer                     NO
#define XVirtualFramebufferServer       NO

#define BuildXWinMultiWindowExtWM       NO
#define EtcX11Directory                 @sysconfdir@
#define ProjectRoot                     @prefix@

I also had to grab xc/lib/font/FreeType from the freedesktop cvs (tag 
CYGWIN if that's relevant). (Using the latest src packages from setup for 
the other sources).

Now when I do xset fp= /usr/X11R6/lib/X11/fonts/TTF/ it doesn't give an 
error, xlsfonts does indeed find those fonts. However, the general problem 
with server-side scaled fonts also applies to truetype and I can't 
actually use the truetype. 

Test case for the server-side scaled fonts bug (#### is any of Speedo, 
TTF, Type1): 
$ xset fp= /usr/X11R6/lib/X11/fonts/####
$ xlsfonts
should work, listing the relevant fonts, but:
$ xfontsel
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  45 (X_OpenFont)
  Serial number of failed request:  11
  Current serial number in output stream:  22

and you get the same error message from any programme that wishes to use 
the server-side fonts (xterm, etc) so its not a bug in xfontsel.


On Thu, 8 Apr 2004, Lev S Bishop wrote:

> I've been doing a little poking, and I'm guessing that the reason 
> server-side truetype doesn't work any more is that we're not building the 
> FreeType module. I think we used to get it by #include <> in 
> which had defaults in to build both the FreeType and 
> XTrueType (as I understand it only one is needed):
> #ifndef BuildFreeType
> # define BuildFreeType		YES
> #endif
> #ifndef BuildXTrueType
> # define BuildXTrueType		YES
> #endif
> However, I tried putting #define BuildFreeType YES in host.def and while 
> it appeared to build FreeType into the font lib, the xwin I got still 
> didn't support Truetype.
> Test case:
> $ xset fp+ /usr/X11R6/lib/X11/fonts/TTF/
> xset:  bad font path element (#58), possible causes are:
>     Directory does not exist or has wrong permissions
>     Directory missing fonts.dir
>     Incorrect font server address or syntax
> Where the directory does exist, does have fonts.dir, no font server is 
> being specified. I can't see any problem with permissions.
> Lev

More information about the Cygwin-xfree mailing list