Possible bug trying to run Eclipse GTK?

Harold L Hunt II huntharo@msu.edu
Fri Apr 2 15:13:00 GMT 2004


seterajunk@CHARTER.NET wrote:

> OK.  I'm fine with all of the FAQ items specified.  (Running an older OpenSSH on Redhat Linux 9).  Here is my XWin.log.  

No, you are not fine unless you tried "ssh -Y" instead of "ssh -X".

Why?  Well, I might just say, "why the heck don't people believe us when 
we try to help them?".

Here it is: OpenSSH has *supported* trusted X11 tunelling for many 
versions; it was changed to be the *default* in the OpenSSH 3.8 
*client*.  So, you can be running an older version of sshd on your Linux 
box and you're still might have trusted X11 tunnelling turned on by 
default since you are using OpenSSH 3.8 as your client.  Another 
interesting thing to note is that you can use an ssh client that doesn't 
support trusted X11 tunelling and you won't have any problems, such as 
PuTTY (free) or SSH Secure Shell (not free).

So, would you please clarify if you actually tried "ssh -Y" instead of 
"ssh -X"?


More information about the Cygwin-xfree mailing list