Various starting X problems
Thu Apr 1 02:05:00 GMT 2004

Now with the workaround of knowing to run startx -- :0 to get X to
start, I thought I'd have a poke about to see what exactly makes it
crash.  I came up with several interesting problems.

In my .xinitrc I *don't* have an explicit path for xterm.  However, I
see xterm has moved from /usr/X11R6/bin to /usr/bin!  Did many other X
applications also move into there?

I only noticed that xterm had moved because when I start X with
-multiwindow (or with -clipboard), it complains like this and exits:

    $ PATH="$PATH:/usr/X11R6/bin" startx -multiwindow -- :0
    XCOMM: not found

    cat: /cygdrive/d/home/luke/.Xauthority: No such file or directory
    xinit:  No such file or directory (errno 2):  no program named "/usr/X11R6/bin/xterm" in PATH

    Specify a program on the command line or make sure that /usr/X11R6/bin
    is in your path.

    waiting for X server to shut down 

    $ head /tmp/XWin.log
    Welcome to the XWin X Server
    Vendor: The Cygwin/X Project

    XWin was started with the following command line:

    /usr/X11R6/bin/X :0 

    ddxProcessArgument - Initializing default screens

(What is XCOMM, BTW?)

However if I start it the same way, but without the -multiwindow, X
starts successfully. (PATH="$PATH:/usr/X11R6/bin" startx -- :0)

If I try to start it with a plain startx (no "--"), I get the usual
illegal option messages (related to having some kind of "traditional"
Chinese or Japanese font installed, I vaguely think), and then it dies
because it thinks a window manager is already running:

    $  PATH="$PATH:/usr/X11R6/bin" startx             
    cat: /cygdrive/d/home/luke/.Xauthority: No such file or directory
    : illegal option -- t
    : illegal option -- r
    : illegal option -- a
    : illegal option -- d
    : illegal option -- i
    : illegal option -- t
    : illegal option -- i
    : illegal option -- o
    : illegal option -- n
    : illegal option -- a
    DISPLAY is :0
    wmaker fatal error: it seems that there is already a window manager running
    xinit:  Bad file descriptor (errno 9):  can't send HUP to process group 3904

    waiting for X server to shut down 

    $ head /tmp/XWin.log
    Welcome to the XWin X Server
    Vendor: The Cygwin/X Project

    XWin was started with the following command line:

    X :0 -multiwindow -clipboard 

    ddxProcessArgument - Initializing default screens

Now, I gather that's because another piece of behaviour changed:

         From: "Danny Staple" <>
      Subject: Re: window manager running already
         Date: Sat, 27 Mar 2004 12:00:57 -0000 (GMT)

    Okay - I was  having this problem as well, after updating.
    What you should do is check if you have an .xinitrc in your home directory.
    As shipped, older versions of cygwin would runa  full screen x, with no
    window manager, and as such - you would have to run one yourself like
    wmaker.  This would then be added to your .xinitrc file.

    The new X is configured with a window manager system which embeds windows
    onto the MS Windows desktop - quite neat when it works - but it means that
    by default, you do not need another window manager. So you probably need
    to remove the window manager lines from your .xinitrc, and possibly even
    remove that altogether if it has nothing else in it.

So if I remove the "exec wmaker" from .xinitrc, X starts and stops
instantly.  So I add an "xterm" at the end of .xinitrc (since X doesn't
realise the wmaker would have started lots of windows from its saved
workspace state if it had been given a few seconds to run).

Also, I see that if I use the MS Windows desktop with -multiwindow, and
right-click on the X taskbar icon to turn off the hiding of the root
window, I get the gray stipple pattern, the window decorations are
stripped off, and the cursor turns into the black X and freezes in
position, so I can't see the cursor until I move it out of the X window
(e.g. down over the Windows taskbar).  Nor can I right-click in the X
desktop background area and call up any menu.

It looks like no window manager is running at all.

I wonder how I can run multiwindow with wmaker as my window manager?
Maybe keep the "exec wmaker" and set display to :1 ...  No, "startx
-multiwindow -- :1" triggers the "no program named
"/usr/X11R6/bin/xterm" in PATH" crash.  So I don't quite see how to
achieve that.  I tried xinit -multiwindow but that started up a full

I tried just running "X -multiwindow" from the command line.  That
appeared to just put the X icon in the taskbar.  I turned off "Hide root
window" then I got just a plain grey stipple.  If I tried to exit from
that, a window popped up saying "There are 0 clients connected.  Do you
want to exit? (Exit) (Cancel)"  Clicking on Exit did nothing. I had to
Hide the root window - that made X exit (with an error message):

    $ X -multiwindow


I'm getting the strong feeling that there's been a lot of changes, and
I am out of touch with the ways you can start and run X.  Can a kind
soul point me at some information?  Related to:

	what the startx defaults are
	can they be modified or overridden by a config file
	using Windows as the WM



More information about the Cygwin-xfree mailing list