Can't get windowmaker to work

Todorovic Vladica-VTODORO1
Fri Mar 21 17:34:00 GMT 2003

Is your $HOME directory on a drive that is text mounted? If so, that's the
problem. Search the archive and you'll see that windowmaker doesn't like
text mounts.

You could change the mount point to be binary, and this should solve the

If you have to use text mounts (like me), you can still get windowmaker to

1. temporarily change your mount to binary. 
2. Run window maker and set it up the way you like. Your settings will be in
$HOME/GNUstep directory.
3. Change mount to text again.
4. Rename GNUstep to .GNUstep (or something similar)
5. mount .GNUstep directory as binary so that it can be accessed as
6. Now you can run windowmaker again, and there should be no signal 11.

This should make windowmaker to believe that the files in GNUstep directory
are unix-like (no cr/lf). At least, it worked for me.


-----Original Message-----
From: Tomasz Rojek []
Sent: Monday, March 17, 2003 12:42 PM
Subject: Re: Can't get windowmaker to work

> When I start wmaker I get a dialog saying "Fatal error Window Maker
> signal 11"
> Have I not installed something??

Your home/$USER directory? I remember that when I had no such directory
created by cygwin (on w2k with SP3 & normal user rights) windowmaker could
not start. Then after getting thru faq and cygwin mailing lists I came to
conclusion to create in my cygwin environment /home/$USER directory and set
is as my $HOME. Try this.

Tomasz Rojek

More information about the Cygwin-xfree mailing list