Font error running app using XDMCP/XWin.exe to Solaris 9 host
Fri Mar 14 21:08:00 GMT 2003

I am sure that I am running a font server on the Solais machine.  When I
connect to it from my cygwin/W2K machine, I can do a 'netstat -an' and see
that the connection has been established on port 7100.  I have tried to
connect in the same way (ie: XDMCP w/-query) using a different commercially
available application produced by Chamelion called Xoftware.  This is
installed on the same W2K machine that cygwin is running on.  Xoftware
seems to work just fine (go figure!).  Others need to have this
functionality but I only have one software license for Xoftware, so I would
really like to get cygwin/XFree86 working.
I suspect that the Solaris font server is providing a font to the cygwin
machine that it does'nt know how to display.  However, I am no expert by
any means when it comes to fonts in general and expecially on Solaris-9.
Anyone have any suggestions beyond those given?

                      Harold L Hunt II                                                                                           
                      <>        To:                                                
                      Sent by:                  cc:                                                                              
                      cygwin-xfree-owner        Fax to:                                                                          
                           Subject:  Re: Font error running app using XDMCP/XWin.exe to Solaris 9 host      
                      03/13/2003 05:36                                                                                           
                      Please respond to                                                                                          


Do you know for sure that you are actually running a font server on said
Solaris machine?  Have you tried connecting to the font server on the
Solaris machine using another X Server, such as MI/X?  Can you check the
logs for xfs on the Solaris machine to see if it is getting the
connection and rejecting it?

Harold wrote:
> Hello all;
> I am connecting to a Solaris 9 host from a W2K host with a batch file
> the following command:
> start XWin -query <sol-9_host> -fp tcp/<sol-9_host>:7100
> When I try to run the application I get the following error:
> X Error of failed request:  BadNane (named color or font does not exeist)
>    Major opcode of failed request:  45  (X_OpenFont)
>    Serial number of failed request:  17
>    Current serial number in output stream:  21
> I am running Cygwin.XFree86 version 4.2.0 on my W2K.  I have tried
> and asundry different combinations of commands and font servers.
> The application draws seismic traces on the screen horizontally along and
> x-y axis depicting amplitude with respect to time.   It just so happens
> that if I point the font server (-fp) at a Solaris Version 2.7 host
> executing the application on the Solaris 9 host) the application runs
> without any errors, but the traces are 'scrunched' down together so as to
> be very difficult to read.
> This same method of connecting to any Linux machine from my W2K machine
> with the above described batch file works without flaw.
> Does anyone have any idea what is going on here, and is there a fix for
> this problem? (I could not find anything mentioning this problem on the
> mailing list archive).  Ofcourse, the reason I am pointing to a different
> font server than the W2K is because for Solaris-9, the login box will not
> get painted (I got this fix off of the archive.)
> -Alan

More information about the Cygwin-xfree mailing list