Font error running app using XDMCP/XWin.exe to Solaris 9 host

Harold L Hunt II
Fri Mar 14 01:36:00 GMT 2003


Do you know for sure that you are actually running a font server on said 
Solaris machine?  Have you tried connecting to the font server on the 
Solaris machine using another X Server, such as MI/X?  Can you check the 
logs for xfs on the Solaris machine to see if it is getting the 
connection and rejecting it?

Harold wrote:
> Hello all;
> I am connecting to a Solaris 9 host from a W2K host with a batch file using
> the following command:
> start XWin -query <sol-9_host> -fp tcp/<sol-9_host>:7100
> When I try to run the application I get the following error:
> X Error of failed request:  BadNane (named color or font does not exeist)
>    Major opcode of failed request:  45  (X_OpenFont)
>    Serial number of failed request:  17
>    Current serial number in output stream:  21
> I am running Cygwin.XFree86 version 4.2.0 on my W2K.  I have tried various
> and asundry different combinations of commands and font servers.
> The application draws seismic traces on the screen horizontally along and
> x-y axis depicting amplitude with respect to time.   It just so happens
> that if I point the font server (-fp) at a Solaris Version 2.7 host (still
> executing the application on the Solaris 9 host) the application runs
> without any errors, but the traces are 'scrunched' down together so as to
> be very difficult to read.
> This same method of connecting to any Linux machine from my W2K machine
> with the above described batch file works without flaw.
> Does anyone have any idea what is going on here, and is there a fix for
> this problem? (I could not find anything mentioning this problem on the
> mailing list archive).  Ofcourse, the reason I am pointing to a different
> font server than the W2K is because for Solaris-9, the login box will not
> get painted (I got this fix off of the archive.)
> -Alan

More information about the Cygwin-xfree mailing list